aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorWill Moss <willormos@gmail.com>2022-11-10 19:55:11 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-27 13:18:29 +0100
commita58146d452c50387256d4a616c055ddf3248496f (patch)
tree88e3904fc0b2290c2c511205f2115e96d76f0510 /target/linux/ath79/image/generic.mk
parent6de9287abd699de5645dc50ce88eefbb60298e7b (diff)
downloadupstream-a58146d452c50387256d4a616c055ddf3248496f.tar.gz
upstream-a58146d452c50387256d4a616c055ddf3248496f.tar.bz2
upstream-a58146d452c50387256d4a616c055ddf3248496f.zip
ath79: D-Link DIR-825 B1 add factory.bin recipe
- Bring back factory.bin image which was missing after porting device to ath79 target - Use default sysupgrade.bin image recipe - Adjust max image size according to new firmware partition size after "ath79: expand rootfs for DIR-825-B1 with unused space (aca8bb5)" changes - Remove support of upgrading from version 19.07, because partition size changes mentioned above Signed-off-by: Will Moss <willormos@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dec9134617..9c209b041f 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1015,12 +1015,14 @@ define Device/dlink_dir-825-b1
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-825
DEVICE_VARIANT := B1
- IMAGE_SIZE := 6208k
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- check-size | append-metadata
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-leds-reset kmod-owl-loader kmod-switch-rtl8366s
- SUPPORTED_DEVICES += dir-825-b1
+ IMAGE_SIZE := 7808k
+ FACTORY_SIZE := 6144k
+ IMAGES += factory.bin
+ IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | check-size $$$$(FACTORY_SIZE) | pad-to $$$$(FACTORY_SIZE) | \
+ append-string 01AP94-AR7161-RT-080619-00
endef
TARGET_DEVICES += dlink_dir-825-b1