aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-03-20 17:57:22 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-30 23:56:47 +0200
commit88527294cda0a46d927b3bca6dbaab507fa1cb96 (patch)
tree80f2d740b8c86cbd79acee04405db2a5912113d0 /target/linux/ath79/image/generic.mk
parent6e9c814022e41a7cfa4db3b1a41e257fd1515bea (diff)
downloadupstream-88527294cda0a46d927b3bca6dbaab507fa1cb96.tar.gz
upstream-88527294cda0a46d927b3bca6dbaab507fa1cb96.tar.bz2
upstream-88527294cda0a46d927b3bca6dbaab507fa1cb96.zip
ath79: add Netgear WNDAP360
SoC: Atheros AR7161 RAM: DDR 128 MiB (hynix h5dU5162ETR-E3C) Flash: SPI-NOR 8 MiB (mx25l6406em2i-12g) WLAN: 2.4/5 GHz 2.4 GHz: Atheros AR9220 5 GHz: Atheros AR9223 Ethernet: 4x 10/100/1000 Mbps (Atheros AR8021) LEDs/Keys: 2/2 (Internet + System LED, Mesh button + Reset pin) UART: RJ45 9600,8N1 Power: 12 VDC, 1.0 A Installation instruction: 0. Make sure you have latest original firmware (3.7.11.4) 1. Connect to the Serial Port with a Serial Cable RJ45 to DB9/RS232 (9600,8N1) screen /dev/ttyUSB0 9600,cs8,-parenb,-cstopb,-hupcl,-crtscts,clocal 2. Configure your IP-Address to 192.168.1.42 3. When device boots hit spacebar 3. Configure the device for tftpboot setenv ipaddr 192.168.1.1 setenv serverip 192.168.1.42 saveenv 4. Reset the device reset 5. Hit again the spacebar 6. Now load the image via tftp: tftpboot 0x81000000 INITRAMFS.bin 7. Boot the image: bootm 0x81000000 8. Copy the squashfs-image to the device. 9. Do a sysupgrade. https://openwrt.org/toh/netgear/wndap360 The device should be converted from kmod-owl-loader to nvmem-cells in the future. Nvmem cells were not working. Maybe ATH9K_PCI_NO_EEPROM is missing. That is why this commit is still using kmod-owl-loader. In the future the device tree may look like this: &ath9k0 { nvmem-cells = <&macaddr_art_120c>, <&cal_art_1000>; nvmem-cell-names = "mac-address", "calibration"; }; &ath9k1 { nvmem-cells = <&macaddr_art_520c>, <&cal_art_5000>; nvmem-cell-names = "mac-address", "calibration"; }; &art { ... cal_art_1000: cal@1000 { reg = <0x1000 0xeb8>; }; cal_art_5000: cal@5000 { reg = <0x5000 0xeb8>; }; }; Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index edf6b7ee5e..4f36a08ff4 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1654,6 +1654,21 @@ define Device/netgear_ex7300-v2
endef
TARGET_DEVICES += netgear_ex7300-v2
+define Device/netgear_wndap360
+ $(Device/netgear_generic)
+ SOC := ar7161
+ DEVICE_MODEL := WNDAP360
+ DEVICE_PACKAGES := kmod-leds-reset kmod-owl-loader
+ IMAGE_SIZE := 7744k
+ BLOCKSIZE := 256k
+ KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+endef
+TARGET_DEVICES += netgear_wndap360
+
define Device/netgear_wndr3x00
$(Device/netgear_generic)
SOC := ar7161