aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2022-04-16 00:23:52 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2022-04-16 01:27:09 +0000
commit5c147d36ba7e998aee7ff4f81553b935bcfc5383 (patch)
treed1c9b9f099bd6f28f7c98cd499f4d9620e567b80 /target/linux/ath79/image/generic.mk
parentecd81de7a5ab4899cc95107b402f7a402caf70bd (diff)
downloadupstream-5c147d36ba7e998aee7ff4f81553b935bcfc5383.tar.gz
upstream-5c147d36ba7e998aee7ff4f81553b935bcfc5383.tar.bz2
upstream-5c147d36ba7e998aee7ff4f81553b935bcfc5383.zip
ath79: port HiWiFi HC6361 from ar71xx
The device was added for ar71xx target and dropped during the ath79 transition, mainly because of the ascii mac address stored in bdinfo partition Device page, http://wiki.openwrt.org/toh/hiwifi/hc6361 The vendor u-boot image accepts sysupgrade.bin image with specific requirements, including having squashfs signature "hsqs" at file offset 0x140000. This is not possible now that OpenWrt kernel image is at least 2MB with the signature at offset 0x240000. Installation of current build of OpenWrt now requires a bootstrap step of installing an earlier version first. - If the vendor u-boot accepts sysupgrade image, hc6361 image of LEDE release should work - If the vendor u-boot accepts only verified flashsmt image, install the one in the above device page. The image is based on Barrier Breaker SHA256SUM of the flashsmt image 81b193b95ea5f8e5c30cd62fa9facf275f39233be4fdeed7038f3deed2736156 After the bootstrap step, current build of OpenWrt can be installed there fine. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dc85fb60bf..80a581a72c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1387,6 +1387,18 @@ define Device/hak5_wifi-pineapple-nano
endef
TARGET_DEVICES += hak5_wifi-pineapple-nano
+define Device/hiwifi_hc6361
+ SOC := ar9331
+ DEVICE_VENDOR := HiWiFi
+ DEVICE_MODEL := HC6361
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-chipidea2 kmod-usb-storage \
+ kmod-fs-ext4 kmod-nls-iso8859-1 e2fsprogs
+ BOARDNAME := HiWiFi-HC6361
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
+ IMAGE_SIZE := 16128k
+endef
+TARGET_DEVICES += hiwifi_hc6361
+
define Device/iodata_etg3-r
SOC := ar9342
DEVICE_VENDOR := I-O DATA