aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2021-02-24 22:55:09 -0500
committerPetr Štetiar <ynezz@true.cz>2021-06-11 07:20:31 +0200
commit64d845ef027b31f3dc8f1a6a692c960a3a8844f3 (patch)
tree3adfe1bc7a6b6bc0b911a228ad4a4f19cb9db769 /target/linux/ath79/image/generic.mk
parent1f6ec4b29ebfda19d9df01f1cc289ed6454683cf (diff)
downloadupstream-64d845ef027b31f3dc8f1a6a692c960a3a8844f3.tar.gz
upstream-64d845ef027b31f3dc8f1a6a692c960a3a8844f3.tar.bz2
upstream-64d845ef027b31f3dc8f1a6a692c960a3a8844f3.zip
ath79: remove 'fakeroot' for Senao devices
By using the same custom kernel header magic in both OKLI lzma-loader, DTS, and makefile this hack is not necessary anymore However, "rootfs" size and checksum must now be supplied by the factory.bin image through a script that is accepted by the OEM upgrade script. This is because Senao OEM scripts assume a squashfs header exists at the offset for the original "rootfs" partition which is actually the kernel + rootfs in this implementation, and takes size value from the header that would be there with hexdump, but this offset is now the uImage header instead. This frees up 1 eraseblock previously used by the "fakeroot" partition for bypassing the OEM image verification. Also, these Senao devices with a 'failsafe' partition and the tar-gz factory.bin platform would otherwise require flashing the new tar-gz sysupgrade.bin afterward. So this also prevents having to flash both images when starting from OEM or 'failsafe' the OEM upgrade script verifies the header magic numbers, but only the first two bytes. Example: [ "${magic_word_kernel}" = "2705" ] && [ "${magic_word_rootfs}" = "7371" -o "${magic_word_rootfs}" = "6873" ] && errcode="0" therefore picked the magic number 0x73714f4b which is 'sqOK' Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit 4a0cc5d4ef29a11914850c72158aca1e2a170fb0)
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk24
1 files changed, 12 insertions, 12 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index f358d44064..bda47ce74d 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -994,8 +994,8 @@ define Device/engenius_eap1200h
DEVICE_VENDOR := EnGenius
DEVICE_MODEL := EAP1200H
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
- IMAGE_SIZE := 11520k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 11584k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := ar71xx-generic-eap1200h
endef
TARGET_DEVICES += engenius_eap1200h
@@ -1006,8 +1006,8 @@ define Device/engenius_eap300-v2
DEVICE_VENDOR := EnGenius
DEVICE_MODEL := EAP300
DEVICE_VARIANT := v2
- IMAGE_SIZE := 12032k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 12096k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := senao-eap300v2
endef
TARGET_DEVICES += engenius_eap300-v2
@@ -1017,8 +1017,8 @@ define Device/engenius_eap600
SOC := ar9344
DEVICE_VENDOR := EnGenius
DEVICE_MODEL := EAP600
- IMAGE_SIZE := 12032k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 12096k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := senao-eap600
endef
TARGET_DEVICES += engenius_eap600
@@ -1054,8 +1054,8 @@ define Device/engenius_ecb600
SOC := ar9344
DEVICE_VENDOR := EnGenius
DEVICE_MODEL := ECB600
- IMAGE_SIZE := 12032k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 12096k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := senao-ecb600
endef
TARGET_DEVICES += engenius_ecb600
@@ -1067,8 +1067,8 @@ define Device/engenius_ens202ext-v1
DEVICE_MODEL := ENS202EXT
DEVICE_VARIANT := v1
DEVICE_PACKAGES := rssileds
- IMAGE_SIZE := 12032k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 12096k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := senao-ens202ext
endef
TARGET_DEVICES += engenius_ens202ext-v1
@@ -1080,8 +1080,8 @@ define Device/engenius_enstationac-v1
DEVICE_MODEL := EnStationAC
DEVICE_VARIANT := v1
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct rssileds
- IMAGE_SIZE := 11520k
- LOADER_FLASH_OFFS := 0x230000
+ IMAGE_SIZE := 11584k
+ LOADER_FLASH_OFFS := 0x220000
SENAO_IMGNAME := ar71xx-generic-enstationac
endef
TARGET_DEVICES += engenius_enstationac-v1