aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJeff Kletsky <git-commits@allycomm.com>2019-03-06 20:44:33 -0800
committerChristian Lamparter <chunkeey@gmail.com>2019-03-13 16:25:34 +0100
commitfefa34def84561688e6af2feeec2dbb390ba4486 (patch)
tree01fa0995ce976d61e4db88bd7acd598c1063e379 /target/linux/ath79/image/generic.mk
parent7dfe357a3d763d6c62ae6fb9620a013356396572 (diff)
downloadupstream-fefa34def84561688e6af2feeec2dbb390ba4486.tar.gz
upstream-fefa34def84561688e6af2feeec2dbb390ba4486.tar.bz2
upstream-fefa34def84561688e6af2feeec2dbb390ba4486.zip
ath79: Add GL.iNet AR-300M-Lite
AR300M-Lite is single-Ethernet variant of the AR300M series Its eth0 would otherwise be assigned to the WAN interface making it unreachable firstboot or failsafe. Installation instructions from OEM (OpenWrt variant): * Install sysupgrade.bin using OEM's "Advanced" GUI (LuCI), * Do not preserve settings * Access rebooted device via Ethernet at OpenWrt default address Add previously missing LED defaults for all three variants; -nand, -nor, -lite to the definitions in 01_leds Non-lite variants thanks to Andreas Ziegler https://patchwork.ozlabs.org/patch/1049396/ Runtime-tested: GL.iNet AR300M-Lite Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6e3dcf0bd8..16212826d8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -313,13 +313,23 @@ define Device/glinet_gl-ar150
endef
TARGET_DEVICES += glinet_gl-ar150
-define Device/glinet_gl-ar300m-nor
+define Device/glinet_gl-ar300m-common-nor
ATH_SOC := qca9531
- DEVICE_TITLE := GL.iNet GL-AR300M
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar300m
endef
+
+define Device/glinet_gl-ar300m-lite
+ $(Device/glinet_gl-ar300m-common-nor)
+ DEVICE_TITLE := GL.iNet GL-AR300M-Lite
+endef
+TARGET_DEVICES += glinet_gl-ar300m-lite
+
+define Device/glinet_gl-ar300m-nor
+ $(Device/glinet_gl-ar300m-common-nor)
+ DEVICE_TITLE := GL.iNet GL-AR300M
+endef
TARGET_DEVICES += glinet_gl-ar300m-nor
define Device/glinet_gl-ar750s