aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDing Tengfei <dtf@comfast.cn>2019-03-21 19:50:01 +0800
committerPetr Štetiar <ynezz@true.cz>2019-03-24 01:44:27 +0100
commitacf149d531c0c263a2869abe09018e7e232a9e41 (patch)
tree42410fbfd5e5076c0b62ae0bd55b48641974b6cf /target/linux/ath79/image/generic.mk
parentfcc716e21d7fa07c68bac8886cef122d35fbbc01 (diff)
downloadupstream-acf149d531c0c263a2869abe09018e7e232a9e41.tar.gz
upstream-acf149d531c0c263a2869abe09018e7e232a9e41.tar.bz2
upstream-acf149d531c0c263a2869abe09018e7e232a9e41.zip
ath79: add support for COMFAST CF-E5/E7
COMFAST CF-E5/E7 is a outdoor 4G LTE AP with PoE support, based on Qualcomm/Atheros QCA9531. Short specification: 2x 10/100 Mbps Ethernet, with 24v PoE support 64 MB of RAM (DDR2) 16 MB of FLASH (SPI) 2T2R 2.4 GHz, 802.11b/g/n built-in 1x 3 dBi antennas output power (max): 80 mW (19 dBm) Qucetel EC20 LTE MODULE(1x external detachable antenna) Flash instruction: Original firmware is based on OpenWrt. Use sysupgrade image directly in vendor GUI. Signed-off-by: Ding Tengfei <dtf@comfast.cn> [commit subject fix] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ddf0e62898..288a6110f6 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -171,6 +171,15 @@ define Device/comfast_cf-e120a-v3
endef
TARGET_DEVICES += comfast_cf-e120a-v3
+define Device/comfast_cf-e5
+ ATH_SOC := qca9531
+ DEVICE_TITLE := COMFAST CF-E5/E7
+ DEVICE_PACKAGES := rssileds kmod-leds-gpio kmod-usb-core kmod-usb2 kmod-usb-net \
+ kmod-usb-net-qmi-wwan -swconfig -uboot-envtools
+ IMAGE_SIZE := 16192k
+endef
+TARGET_DEVICES += comfast_cf-e5
+
define Device/devolo_dvl1200e
ATH_SOC := qca9558
DEVICE_TITLE := devolo WiFi pro 1200e