aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-03-16 13:27:32 +0900
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 19:14:06 +0200
commit643fcfc8d64563d6c581a899ff839c9a91432e98 (patch)
tree52c375338d37c21dcf61c80977666f9052ac119d /target/linux/ath79/image/generic.mk
parentfac27643f057d681ec276828dc4d1ba7159b5680 (diff)
downloadupstream-643fcfc8d64563d6c581a899ff839c9a91432e98.tar.gz
upstream-643fcfc8d64563d6c581a899ff839c9a91432e98.tar.bz2
upstream-643fcfc8d64563d6c581a899ff839c9a91432e98.zip
ath79: add support for NEC Aterm WG1200CR
NEC Aterm WG1200CR is a 2.4/5 GHz band 11ac router, based on Qualcomm Atheros QCA9563. Specification: - SoC : Qualcomm Atheros QCA9563 - RAM : DDR2 128 MiB - Flash : SPI-NOR 8 MiB - WLAN : 2.4/5 GHz 2T2R - 2.4 GHz : QCA9563 (SoC) - 5 GHz : QCA9888 - Ethernet : 2x 10/100/1000 Mbps - Switch : QCA8334 - LEDs/Input : 12x/4x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - JP1: Vcc, GND, NC, TX, RX from power connector side - 115200 bps Flash instruction using factory image: 1. Boot WG1200CR normaly 2. Access to "http://192.168.10.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click update ("更新") button to perform firmware update 4. Wait ~150 seconds to complete flashing Known issues: - cannot be controlled LEDs other than Power (Green/Red) - only Power LEDs are connected to SoC GPIO; other LEDs connected to the gpiochip on ath10k chip (QCA9888) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [commit message formatting]
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 288a6110f6..0d5ad171f1 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -42,6 +42,12 @@ define Build/add-elecom-factory-initramfs
fi
endef
+define Build/nec-enc
+ $(STAGING_DIR_HOST)/bin/nec-enc \
+ -i $@ -o $@.new -k $(1)
+ mv $@.new $@
+endef
+
define Build/nec-fw
( stat -c%s $@ | tr -d "\n" | dd bs=16 count=1 conv=sync; ) >> $@
( \
@@ -446,6 +452,24 @@ define Device/librerouter_librerouter-v1
endef
TARGET_DEVICES += librerouter_librerouter-v1
+define Device/nec_wg1200cr
+ ATH_SOC := qca9563
+ DEVICE_TITLE := NEC Aterm WG1200CR
+ IMAGE_SIZE := 7616k
+ SEAMA_MTDBLOCK := 6
+ SEAMA_SIGNATURE := wrgac72_necpf.2016gui_wg1200cr
+ IMAGES += factory.bin
+ IMAGE/default := \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
+ IMAGE/sysupgrade.bin := \
+ $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | nec-enc 9gsiy9nzep452pad | \
+ check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += nec_wg1200cr
+
define Device/nec_wg800hp
ATH_SOC := qca9563
DEVICE_TITLE := NEC Aterm WG800HP