aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-06-11 17:27:51 +0200
committerDavid Bauer <mail@david-bauer.net>2019-07-21 13:09:45 +0200
commit5cd9b50d69cb42d55b9cc466b749b41d1da465de (patch)
treee6be050a234abb4b68213b4a91852f69bb0ddf0e /target/linux/ath79/image/generic.mk
parent76a4c93f9dcafc0efd6f825fbd40eb4a2e53d456 (diff)
downloadupstream-5cd9b50d69cb42d55b9cc466b749b41d1da465de.tar.gz
upstream-5cd9b50d69cb42d55b9cc466b749b41d1da465de.tar.bz2
upstream-5cd9b50d69cb42d55b9cc466b749b41d1da465de.zip
ath79: add support for devolo WiFi pro 1750x
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) WiFi2: QCA9558 3T3R WiFi5: QCA9880 3T3R BTN: 1x Reset LED: 1x LED Power (non-controllable) 1x LED Status (internal) 1x LED LAN (controlled by PHY) 1x LED WLAN BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to external-LED header. Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit cb3cd526948af3f69da1af18e035177a0a8f58e3)
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d5f67b88a6..4bfdd69d6d 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -243,6 +243,14 @@ define Device/devolo_dvl1750i
endef
TARGET_DEVICES += devolo_dvl1750i
+define Device/devolo_dvl1750x
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1750x
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750x
+
define Device/dlink_dir-825-b1
ATH_SOC := ar7161
DEVICE_TITLE := D-LINK DIR-825 B1