aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-02-01 20:48:41 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-02-11 19:04:06 +0100
commit0c24b363a69d1445a280e41e5c33675be95295d1 (patch)
tree16756d1854fc028e917a1634066ce030b8d76d0a /target/linux/ath79/image/generic.mk
parent4130e24326d6a7bea6f786589baf65dc992c97a5 (diff)
downloadupstream-0c24b363a69d1445a280e41e5c33675be95295d1.tar.gz
upstream-0c24b363a69d1445a280e41e5c33675be95295d1.tar.bz2
upstream-0c24b363a69d1445a280e41e5c33675be95295d1.zip
ath79: add support for Xiaomi Mi Router 4Q
Hardware -------- CPU: Qualcomm Atheros QCA9561 RAM: 64M DDR2 FLASH: 16M SPI-NOR ETH: 1x WAN - 2x LAN WiFi: QCA9561 3T3R BTN: 1x Reset - 1x WPS LED: 1x Blue - 1x Red - 1x Yellow UART: TX - GND - RX - VCC (From ethernet port) 115200n8 - 3.3V Installation ------------ 1. Connect to the device via UART. 2. Interrupt the U-Boot on power-on by pressing enter when prompted. 3. Connect you computer to one of the routers LAN ports. Assign yourself the IP 192.168.31.10/24. Copy the OpenWRT initramfs image to a tftp server root directory. Rename the image to 'x4q.bin'. 4. Load the initramfs image to the router by executing following command in U-Boot. The image will boot afterwards. > tftpboot 0x81000000 x4q.bin; bootm 5. SCP the sysupgrade-image into '/tmp'. Remember to assign yourself an IP in 192.168.1.0/24 for this step! 6. Install OpenWRT permanently by executing > sysupgrade -n /tmp/<OpenWRT-sysupgrade-image> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9d0412fe97..94dfe3d4d7 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -528,3 +528,10 @@ define Device/winchannel_wb2000
DEVICE_PACKAGES := kmod-i2c-core kmod-i2c-gpio kmod-rtc-ds1307 kmod-usb2 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += winchannel_wb2000
+
+define Device/xiaomi_mi-router-4q
+ ATH_SOC := qca9561
+ DEVICE_TITLE := Xiaomi Mi Router 4Q
+ IMAGE_SIZE := 14336k
+endef
+TARGET_DEVICES += xiaomi_mi-router-4q