aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-02-08 12:58:25 +0100
committerDavid Bauer <mail@david-bauer.net>2020-02-16 15:36:29 +0100
commitd2b8ccb1c04def81224da6f42f644c7d239b9986 (patch)
tree29ba990cb0f9f2e38ff97484a221ce94a9f511f8 /target/linux/ath79/image/generic.mk
parentae35ff576764fb68b84fcac070e5d2b1ccb4966d (diff)
downloadupstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.tar.gz
upstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.tar.bz2
upstream-d2b8ccb1c04def81224da6f42f644c7d239b9986.zip
ath79: add support for Siemens WS-AP3610
Hardware -------- SoC: Atheros AR7161 RAM: Samsung K4H511638D-UCCC 2x 64M DDR1 SPI: Micron M25P128 (16M) WiFi: Atheros AR9160 bgn Atheros AR9160 an ETH: Broadcom BCM5481 LED: Power (Green/Red) ETH (Green / Blue / Yellow) (PHY-controlled) WiFi 5 (Green / Blue) WiFi 2 (Green / Blue) BTN: Reset Serial: Cisco-Style RJ45 - 115200 8N1 Installation ------------ 1. Download the OpenWrt initramfs-image. Place it into a TFTP server root directory and rename it to 1401A8C0.img. Configure the TFTP server to listen at 192.168.1.66/24. 2. Connect the TFTP server to the access point. 3. Connect to the serial console of the access point. Attach power and interrupt the boot procedure when prompted (bootdelay is 1 second). 4. Configure the U-Boot environment for booting OpenWrt from Ram and flash: $ setenv boot_openwrt 'setenv bootargs; bootm 0xbf080000' $ setenv ramboot_openwrt 'setenv serverip 192.168.1.66; tftpboot; bootm' $ saveenv 5. Load OpenWrt into memory: $ run ramboot_openwrt Wait for the image to boot. 6. Transfer the OpenWrt sysupgrade image to the device. Write the image to flash using sysupgrade: $ sysupgrade -n /path/to/openwrt-sysuograde.bin Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 05d2ba6a75..d4693cea68 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1041,6 +1041,20 @@ define Device/rosinson_wr818
endef
TARGET_DEVICES += rosinson_wr818
+define Device/siemens_ws-ap3610
+ SOC := ar7161
+ DEVICE_VENDOR := Siemens
+ DEVICE_MODEL := WS-AP3610
+ IMAGE_SIZE := 14336k
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x82000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 8128 | uImage none
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+endef
+TARGET_DEVICES += siemens_ws-ap3610
+
define Device/sitecom_wlr-7100
SOC := ar1022
DEVICE_VENDOR := Sitecom