aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-01-12 20:20:43 +0100
committerJohn Crispin <john@phrozen.org>2020-01-15 20:38:46 +0100
commitc9ac7b17296ff29d9df39db8a68c449ef1514bbd (patch)
tree7c5262a7f05c0ee5990010dc2ef1fb7e110de782 /target/linux/ath79/image/generic.mk
parent475a504dbc05e7a7e7d38db426c657b8c0c834fd (diff)
downloadupstream-c9ac7b17296ff29d9df39db8a68c449ef1514bbd.tar.gz
upstream-c9ac7b17296ff29d9df39db8a68c449ef1514bbd.tar.bz2
upstream-c9ac7b17296ff29d9df39db8a68c449ef1514bbd.zip
ath79: add support for D-Link DIR-505
This commit adds support for the D-Link DIR-505, previously supported in ar71xx. Hardware -------- SoC: Atheros AR9330 FLASH: 8M SPI-NOR RAM: 64M WIFI: 1T1R 1SS Atheros AR9330 LED: Power green, Status red BTN: WPS, Reset Installation ------------ Currently, installation is only possible by sysupgrading from an earlier OpenWrt version, U-Boot TFTP or a modded U-Boot. I do not have the original bootloader from D-Link on my device anymore, so i cannot test the factory image. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index abc6f96a80..800e1c7a7d 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -373,6 +373,16 @@ define Device/devolo_dvl1750x
endef
TARGET_DEVICES += devolo_dvl1750x
+define Device/dlink_dir-505
+ SOC := ar9330
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DIR-505
+ IMAGE_SIZE := 7680k
+ DEVICE_PACKAGES := kmod-usb2
+ SUPPORTED_DEVICES += dir-505-a1
+endef
+TARGET_DEVICES += dlink_dir-505
+
define Device/dlink_dir-825-b1
SOC := ar7161
DEVICE_VENDOR := D-Link