aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-12-27 02:32:39 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-27 14:06:38 +0100
commite67da3443168fa6b6727cd81a35d559be77d6b4c (patch)
tree601ffc3a594a02a7e2102852e8c907aa26e69927 /target/linux/ath79/image/generic.mk
parent1724d4e9ed7716a5444eca42adf045c2f3afc554 (diff)
downloadupstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.tar.gz
upstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.tar.bz2
upstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.zip
ath79: add support for devolo WiFi pro 1750c
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) WiFi2: QCA9558 3T3R WiFi5: QCA9880 3T3R BTN: 1x Reset LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to reset-button There is also a Micro-B USB-port present but this only seems to be a dummy as the circuit next to it is not present (at least in my unit). It is also not mentioned in the devolo manual. Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ef8cf170de..b2f83ba58c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -146,6 +146,14 @@ define Device/devolo_dvl1200e
endef
TARGET_DEVICES += devolo_dvl1200e
+define Device/devolo_dvl1750c
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1750c
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750c
+
define Device/dlink_dir-825-b1
ATH_SOC := ar7161
DEVICE_TITLE := D-LINK DIR-825 B1