aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-12-30 00:55:35 +0900
committerINAGAKI Hiroshi <musashino.open@gmail.com>2018-12-31 21:38:53 +0900
commitcaf306ce912a46e2d1204b996c3b4fede9af6dae (patch)
tree99aa191461409cec146725055d4537744e1914a4 /target/linux/ath79/image/generic.mk
parentab12913676b05c069f36eda827043c6b83e51dbe (diff)
downloadupstream-caf306ce912a46e2d1204b996c3b4fede9af6dae.tar.gz
upstream-caf306ce912a46e2d1204b996c3b4fede9af6dae.tar.bz2
upstream-caf306ce912a46e2d1204b996c3b4fede9af6dae.zip
ath79: add support for ELECOM WRC-1750GHBK2-I/C
ELECOM WRC-1750GHBK2-I/WRC-1750GHBK2-C are 2.4/5 GHz band 11ac routers, based on Qualcomm Atheros QCA9563. This commit also includes small fix; use "0x0x03000101" as pll_1000 instead of "0x03000000". Specification: - SoC: Qualcom Atheros QCA9563 - RAM: 128 MB (DDR2) - Flash: 16 MB (SPI-NOR) - WLAN: 2.4/5 GHz - 2.4 GHz: 2T2R (SoC internal) - 5 GHz: 3T3R (QCA9880) - Ethernet: 10/100/1000 Mbps - LED/key: 4x/3x (2x buttons, 1x slide-switch) - UART: through-hole on PCB - Vcc, RX, GND, TX from switch (QCA8337N) side - 115200n8 Flash instruction using factory image: 1. Boot WRC-1750GHBK2-I/C normaly 2. Access to "http://192.168.2.1/" and open firmware upgrade page ("ファームウェア更新 手動更新(アップデート)") 3. Select the OpenWrt factory image and click apply ("適用") button to perform firmware update 4. On the (initramfs) factory image, perform sysupgrade with squashfs-sysupgrade image 5. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2f9b2c9d7e..31c62f659d 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -221,6 +221,17 @@ define Device/dlink_dir-859-a1
endef
TARGET_DEVICES += dlink_dir-859-a1
+define Device/elecom_wrc-1750ghbk2-i
+ ATH_SOC := qca9563
+ DEVICE_TITLE := ELECOM WRC-1750GHBK2-I/C
+ IMAGE_SIZE := 15808k
+ KERNEL_INITRAMFS := $$(KERNEL) | pad-to 2 | \
+ elecom-header 16187314 RN68 WRC-1750GHBK2 \
+ $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.bin
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += elecom_wrc-1750ghbk2-i
+
define Device/elecom_wrc-300ghbk2-i
ATH_SOC := qca9563
DEVICE_TITLE := ELECOM WRC-300GHBK2-I