aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-01-01 19:17:23 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-05 21:55:22 +0100
commitc8115167f946be85f812f3c94d6294b67ac8944c (patch)
tree5eecd280d999a0081af4bd015f980a933147db26 /target/linux/ath79/image/generic.mk
parent8d68be8057d6c689025cc236d20b96b77a6ccf30 (diff)
downloadupstream-c8115167f946be85f812f3c94d6294b67ac8944c.tar.gz
upstream-c8115167f946be85f812f3c94d6294b67ac8944c.tar.bz2
upstream-c8115167f946be85f812f3c94d6294b67ac8944c.zip
ath79: add support for devolo WiFi pro 1200i
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) WiFi2: QCA9558 2T2R WiFi5: QCA9880 2T2R BTN: 1x Reset LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to reset-button Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 438a842182..22ba5305b1 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -170,6 +170,14 @@ define Device/devolo_dvl1200e
endef
TARGET_DEVICES += devolo_dvl1200e
+define Device/devolo_dvl1200i
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1200i
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1200i
+
define Device/devolo_dvl1750c
ATH_SOC := qca9558
DEVICE_TITLE := devolo WiFi pro 1750c