aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2018-12-30 16:36:22 +0000
committerMathias Kresin <dev@kresin.me>2018-12-31 13:28:20 +0100
commitaf28d8a539fe64bfc893f798fdbbc49b4e78352a (patch)
treef56fca25dbc15225c203d0b8f66a671e56bbb72b /target/linux/ath79/image/generic.mk
parent213c0e78fa57bbb52745b8dae6efaf5506378ebf (diff)
downloadupstream-af28d8a539fe64bfc893f798fdbbc49b4e78352a.tar.gz
upstream-af28d8a539fe64bfc893f798fdbbc49b4e78352a.tar.bz2
upstream-af28d8a539fe64bfc893f798fdbbc49b4e78352a.zip
ath79: add support for GL.iNet GL-AR750S
Right now this patch adds nor image generation only. NAND image generation is not supportet at the moment. Furtheremore support for the MicroSD port is not implemented as of now. Specification: - SOC: QCA9563 (775MHz) - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR2 - Ethernet: 2x 1Gbps LAN + 1x 1Gbps WAN - Wireless: 2.4GHz (bgn) and 5GHz (ac) - USB: 1x USB 2.0 port - Button: 1x switch button, 1x reset button - LED: 3x LEDS (green) - Another LED can be accessed on GPIO 7 if soldered Flash instruction: - Set static ip to 192.168.1.2 - Unplug the power cord - Hold reset button - Plug power back in - Right led will flash 5 times - Release reset button - Browse to 192.168.1.1 - Choose sysupgrade image in NOR-flash section - Press "update nor firmware" - After successful transfer unplug network cable before device restarts Signed-off-by: Christoph Krapp <achterin@googlemail.com> [resolve merge conflicts, rename buttons, use switch input type for mode switch] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8dd5dab7ca..2f9b2c9d7e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -266,6 +266,15 @@ define Device/glinet_ar300m-nor
endef
TARGET_DEVICES += glinet_ar300m-nor
+define Device/glinet_ar750s
+ ATH_SOC := qca9563
+ DEVICE_TITLE := GL.iNet GL-AR750S
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 16000k
+ SUPPORTED_DEVICES += gl-ar750s
+endef
+TARGET_DEVICES += glinet_ar750s
+
define Device/glinet_gl-x750
ATH_SOC := qca9531
DEVICE_TITLE := GL.iNet GL-X750