aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2019-05-05 12:56:03 -0500
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 16:44:41 +0200
commitaee5c9861996983394ac49f91a831c4641a4bf83 (patch)
tree9a7bf1ad39ce0b9c8706e5798efc937c1082112d /target/linux/ath79/image/generic.mk
parent2fdd02cc7c3516c2cce2ace2c7b539e0821ecbe8 (diff)
downloadupstream-aee5c9861996983394ac49f91a831c4641a4bf83.tar.gz
upstream-aee5c9861996983394ac49f91a831c4641a4bf83.tar.bz2
upstream-aee5c9861996983394ac49f91a831c4641a4bf83.zip
ath79: add support for Aruba AP-105
SoC: Atheros AR7161-8C1A @ 680 MHz RAM: 128MB - 2x Etron Technology EM6AB160TSA-5G NOR: 16MB - 1x MXIC MX25L12845EMI-10G (SPI-NOR) WI1: Atheros AR9223-AC1A 802.11bgn WI2: Atheros AR9220-AC1A 802.11an ETH: Atheros AR8021-BL1E + PoE LED: Dual-Color Power/Status, Ethernet, WLAN2G and WLAN5G BTN: 1 x Reset I2C: AT97SC4303s TPM (needs driver!) CON: RS232-level 8P8C/RJ45 Console Port - 9600 Baud Factory installation: - Needs a u-boot replacement. See Wiki for information on how to do a in-circut flash with a SPI-Flasher like a CH314A or flashrom. Wiki page can be found at https://openwrt.org/toh/aruba/aruba_ap-105 - Be careful when dis- and reassembling the device to not squish any of the antenna cables in the process! - Be sure to make a full 16 MiB backup of your device before flashing the new u-boot! This is needed if you ever have interest in reverting back to stock firmware. Not working: - TPM (needs a driver) Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a96c9d279a..dd5843d436 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -75,6 +75,14 @@ define Device/seama
SEAMA_SIGNATURE :=
endef
+define Device/aruba_ap-105
+ ATH_SOC := ar7161
+ DEVICE_TITLE := Aruba AP-105
+ IMAGE_SIZE := 16000k
+ DEVICE_PACKAGES := kmod-i2c-core kmod-i2c-gpio kmod-tpm-i2c-atmel
+endef
+TARGET_DEVICES += aruba_ap-105
+
define Device/avm_fritz300e
ATH_SOC := ar7242
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E