aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2018-12-29 17:22:32 +0800
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:13 +0100
commitabc7ed2c58860fc1363129efbe9e8c60f81a802c (patch)
tree972d250921df3ca509c8a98aa514a0e774c1e5b6 /target/linux/ath79/image/generic.mk
parentfd35c5b205e7583628472b607ee4eb41c6d1b6d5 (diff)
downloadupstream-abc7ed2c58860fc1363129efbe9e8c60f81a802c.tar.gz
upstream-abc7ed2c58860fc1363129efbe9e8c60f81a802c.tar.bz2
upstream-abc7ed2c58860fc1363129efbe9e8c60f81a802c.zip
ath79: add support for D-Link DIR-859 A1
Hardware spec of DIR-859 A1: SoC: QCA9563 DRAM: 64MB DDR2 Flash: 16MB SPI-NOR Switch: QCA8337N WiFi 5.8GHz: QCA9880 USB is supported on the PCB but not connected. Flash instructions: 1. Upgrade the factory.bin through the factory web interface or the u-boot failsafe interface. The firmware will boot up correctly for the first time. Do not power off the device after OpenWrt has booted. Otherwise the u-boot will enter failsafe mode as the checksum of the firmware has been changed. 2. Upgrade the sysupgrade.bin in OpenWrt. After upgrading completes the u-boot won't complain about the firmware checksum and it's OK to use now. 3. If you powered off the device before upgrading the sysupgrade.bin, just upgrade the factory.bin through the u-boot failsafe interface and then goto step 2. Signed-off-by: Weijie Gao <hackpascal@gmail.com> [squash commits, use common seama recipes, sync factory image recipe with ramips version] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b2f83ba58c..8dd5dab7ca 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2,6 +2,7 @@ include ./common-buffalo.mk
include ./common-netgear.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
+DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
define Build/cybertan-trx
@echo -n '' > $@-empty.bin
@@ -53,6 +54,23 @@ define Build/nec-fw
mv $@.new $@
endef
+define Device/seama
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
+ KERNEL_INITRAMFS := $$(KERNEL) | seama
+ IMAGES += factory.bin
+ SEAMA_MTDBLOCK := 1
+
+ # 64 bytes offset:
+ # - 28 bytes seama_header
+ # - 36 bytes of META data (4-bytes aligned)
+ IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
+ IMAGE/sysupgrade.bin := \
+ $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size $$$$(IMAGE_SIZE)
+ SEAMA_SIGNATURE :=
+endef
+
define Device/avm_fritz300e
ATH_SOC := ar7242
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
@@ -192,6 +210,17 @@ define Device/dlink_dir-835-a1
endef
TARGET_DEVICES += dlink_dir-835-a1
+define Device/dlink_dir-859-a1
+ $(Device/seama)
+ ATH_SOC := qca9563
+ DEVICE_TITLE := D-LINK DIR-859 A1
+ IMAGE_SIZE := 15872k
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ SEAMA_SIGNATURE := wrgac37_dlink.2013gui_dir859
+ SUPPORTED_DEVICES += dir-859-a1
+endef
+TARGET_DEVICES += dlink_dir-859-a1
+
define Device/elecom_wrc-300ghbk2-i
ATH_SOC := qca9563
DEVICE_TITLE := ELECOM WRC-300GHBK2-I