aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-09-11 20:50:35 +0900
committerMathias Kresin <dev@kresin.me>2018-09-26 20:35:07 +0200
commit81f7bdcb8d6284dbc291b7300c536359c8a528bd (patch)
tree133d6ac7fa7933791328631b06acdf2586a37c93 /target/linux/ath79/image/generic.mk
parent1df1ea4d7e8b6ae3351780ed58800ccd9edd4c27 (diff)
downloadupstream-81f7bdcb8d6284dbc291b7300c536359c8a528bd.tar.gz
upstream-81f7bdcb8d6284dbc291b7300c536359c8a528bd.tar.bz2
upstream-81f7bdcb8d6284dbc291b7300c536359c8a528bd.zip
ath79: add support for Buffalo BHR-4GRV
Buffalo BHR-4GRV is a wired router, based on Atheros AR7242. Specification: - Atheros AR7242 - 64 MB of RAM - 32 MB of Flash - 2x 16 MB SPI-NOR flash - 5x 10/100/1000 Mbps Ethernet - 3x LEDs, 2x keys - 1x USB 2.0 Type-A - UART header on PCB - JP1: Vcc, GND, TX, RX from reset button side Flash instruction using factory image: 1. Boot the BHR-4GRV normaly and connect the computer to its LAN port 2. Access to "http://192.168.11.1/cgi-bin/cgi?req=frm&frm=py-db/firmup.html" with user "bufpy" and password "otdpopy" 3. Select the OpenWrt factory image and click "OK" button to perform firmware upgrade 4. Wait ~200 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 91325cf4d4..39f59524d9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -69,6 +69,19 @@ define Device/avm_fritz4020
endef
TARGET_DEVICES += avm_fritz4020
+define Device/buffalo_bhr-4grv
+ ATH_SOC := ar7242
+ DEVICE_TITLE := Buffalo BHR-4GRV
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ IMAGE_SIZE := 32256k
+ IMAGES += factory.bin tftp.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc BHR-4GRV 1.99 | buffalo-tag BHR-4GRV
+ IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
+ SUPPORTED_DEVICES += wzr-hp-g450h
+endef
+TARGET_DEVICES += buffalo_bhr-4grv
+
define Device/buffalo_wzr-hp-ag300h
ATH_SOC := ar7161
DEVICE_TITLE := Buffalo WZR-HP-AG300H