aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-07 18:53:37 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-07 19:06:57 +0100
commit5fc63ec8a496066d101de41ae4f820c5c4e39c04 (patch)
tree70989c58557aac961e5f200a5f265d5eb6a5b08f /target/linux/ath79/image/generic.mk
parent2b4d9b68500146b6ef16c798bebb5e0fdcae170f (diff)
downloadupstream-5fc63ec8a496066d101de41ae4f820c5c4e39c04.tar.gz
upstream-5fc63ec8a496066d101de41ae4f820c5c4e39c04.tar.bz2
upstream-5fc63ec8a496066d101de41ae4f820c5c4e39c04.zip
ath79: disable building future NAND images for GL-AR300M/GL-AR750S
To simplify the upgrade process and ensure easier identification of device partitioning, the following devices are disabled on ath79 target in openwrt-19.07 branch: - glinet,gl-ar300m-nor - glinet,gl-ar300m-nand - glinet,gl-ar750s Proper ath79 (NAND) support for the devices is expected to be introduced based on kernel 4.19 (see GitHub PR #2184). In openwrt-19.07, ar71xx should be used for those devices. With this, we ensure that the new ath79 image names (at least for releases) refer to the updated partitioning. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3b7fdb7015..625c2bdd05 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -395,7 +395,7 @@ define Device/glinet_gl-ar300m-nor
$(Device/glinet_gl-ar300m-common-nor)
DEVICE_TITLE := GL.iNet GL-AR300M
endef
-TARGET_DEVICES += glinet_gl-ar300m-nor
+#TARGET_DEVICES += glinet_gl-ar300m-nor
define Device/glinet_gl-ar750s
ATH_SOC := qca9563
@@ -404,7 +404,7 @@ define Device/glinet_gl-ar750s
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar750s
endef
-TARGET_DEVICES += glinet_gl-ar750s
+#TARGET_DEVICES += glinet_gl-ar750s
define Device/glinet_gl-x750
ATH_SOC := qca9531