aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-08-11 14:47:21 +0300
committerMathias Kresin <dev@kresin.me>2018-08-13 08:37:19 +0200
commitb58df9919ef827e4d591e8b1990f0d306f7bdb5f (patch)
treedbb07b38e540c95a01e5087502239aab6463dd89 /target/linux/ath79/image/generic.mk
parent1d3ea7874df420ab8d3acbddf5ec9251bf79ed9b (diff)
downloadupstream-b58df9919ef827e4d591e8b1990f0d306f7bdb5f.tar.gz
upstream-b58df9919ef827e4d591e8b1990f0d306f7bdb5f.tar.bz2
upstream-b58df9919ef827e4d591e8b1990f0d306f7bdb5f.zip
ath79: create WNDR3700 series .dtsi and adjust WNDR3800
Prepare for addition of WNDR3700 and WNDR3700v2 by separating the common parts into wndr3700.dtsi and leaving just the device-specific things into wndr3800.dts The three routers are identical except * device IDs * WNDR3700 (v1) has only 8 MB flash, while others have 16 MB. Partition structure needs to be defined for each device. * (WNDR3800 has 128 MB RAM, but RAM size is not in DTS) Also separate the common parts of the image recipe. (Drop also the initramfs recipe.) Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a32136a40b..6aaee7015a 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -134,20 +134,23 @@ define Device/pcs_cr5000
endef
TARGET_DEVICES += pcs_cr5000
-define Device/netgear_wndr3800
+define Device/netgear_wndr3x00
ATH_SOC := ar7161
- DEVICE_TITLE := NETGEAR WNDR3800
- NETGEAR_KERNEL_MAGIC := 0x33373031
KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
- KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
- NETGEAR_BOARD_ID := WNDR3800
- NETGEAR_HW_ID := 29763654+16+128
- IMAGE_SIZE := 15872k
IMAGES := sysupgrade.bin factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport kmod-leds-reset
+endef
+
+define Device/netgear_wndr3800
+ $(Device/netgear_wndr3x00)
+ DEVICE_TITLE := NETGEAR WNDR3800
+ NETGEAR_KERNEL_MAGIC := 0x33373031
+ NETGEAR_BOARD_ID := WNDR3800
+ NETGEAR_HW_ID := 29763654+16+128
+ IMAGE_SIZE := 15872k
SUPPORTED_DEVICES += wndr3800
endef
TARGET_DEVICES += netgear_wndr3800