aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorIcenowy Zheng <icenowy@aosc.io>2018-08-12 22:32:01 +0800
committerMathias Kresin <dev@kresin.me>2018-08-14 10:19:37 +0200
commitb2a33d5463e88b74b021711d7f392edeafe61041 (patch)
treedfd4f003f5586d667ac463cab72501754ef8c983 /target/linux/ath79/image/generic.mk
parent03e5dcbf10b1f67a463735efd8db3386f91473fd (diff)
downloadupstream-b2a33d5463e88b74b021711d7f392edeafe61041.tar.gz
upstream-b2a33d5463e88b74b021711d7f392edeafe61041.tar.bz2
upstream-b2a33d5463e88b74b021711d7f392edeafe61041.zip
ath79: add support for Pisen WMM003N (Cloud Easy Power)
Pisen WMM003N (sold under the name of Cloud Easy Power) is an AR9331-based router and power bank combo device. The device uses a stock firmware modified from OpenWRT for TP-Link TL-WR703N; however some GPIO definition is different on this device with TL-WR703N. An AXP202 PMIC (connected to a 5000mAh battery) and a SD slot are also added, and the stock Flash/RAM configuration is 8MiB/64MiB. The stock firmware is an old and heavily modified OpenWRT-based firmware, which has telnetd defaultly open, and the root password is "ifconfig" (quotation marks not included). The factory image format is not known yet, however the stock firmware ships the OpenWRT's sysupgrade command, and it can be used to install a newer firmware. Due to the lack of the access to the STM8 embedded controller, the SD slot is currently not usable (because it's muxed with the on-board USB port) and the AXP PMIC cannot be monitored. Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ddde8beee8..117198f70b 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -167,6 +167,17 @@ define Device/netgear_wndr3700v2
endef
TARGET_DEVICES += netgear_wndr3700v2
+define Device/pisen_wmm003n
+ $(Device/tplink-8mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := Pisen WMM003N (Cloud Easy Power)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-chipidea2
+ TPLINK_HWID := 0x07030101
+ SUPPORTED_DEVICES += wmm003n
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += pisen_wmm003n
+
define Device/netgear_wndr3800
$(Device/netgear_wndr3x00)
DEVICE_TITLE := NETGEAR WNDR3800