aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDmitry Tunin <hanipouspilot@gmail.com>2018-08-09 20:49:29 +0300
committerMathias Kresin <dev@kresin.me>2018-08-11 21:45:04 +0200
commit97de133368762824ba3d7e9d95f97011a597ec1a (patch)
treed55d2e625ccfa22b897ae3f3be075a2b2a7cefc8 /target/linux/ath79/image/generic.mk
parenta441c86d93657121afe8117f8329b7095f7154d2 (diff)
downloadupstream-97de133368762824ba3d7e9d95f97011a597ec1a.tar.gz
upstream-97de133368762824ba3d7e9d95f97011a597ec1a.tar.bz2
upstream-97de133368762824ba3d7e9d95f97011a597ec1a.zip
ath79: add support of D-Link DIR-825 B1
Add support for the ar71xx supported D-Link DIR-825 B1 to ath79. Signed-off-by: Dmitry Tunin <hanipouspilot@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 614b3371f3..767d635cfb 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -22,6 +22,16 @@ define Device/buffalo_wzr-hp-g450h
endef
TARGET_DEVICES += buffalo_wzr-hp-g450h
+define Device/dlink_dir-825-b1
+ ATH_SOC := ar7161
+ DEVICE_TITLE := D-LINK DIR-825 B1
+ IMAGE_SIZE := 6208k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport kmod-leds-reset kmod-owl-loader
+ SUPPORTED_DEVICES += dir-825-b1
+endef
+TARGET_DEVICES += dlink_dir-825-b1
+
define Device/embeddedwireless_dorin
ATH_SOC := ar9331
DEVICE_TITLE := Embedded Wireless Dorin