aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-09-11 18:32:05 +0200
committerDavid Bauer <mail@david-bauer.net>2020-09-17 18:07:39 +0200
commitb7da0d294465d5ab8d923f3b8265ece0a5847ac3 (patch)
tree51f6e7712cdd3f7559181dfbc04d6eb8098afc71 /target/linux/ath79/image/generic-ubnt.mk
parentcaf727767ab5c8f8d884ef458c74726a8e610d96 (diff)
downloadupstream-b7da0d294465d5ab8d923f3b8265ece0a5847ac3.tar.gz
upstream-b7da0d294465d5ab8d923f3b8265ece0a5847ac3.tar.bz2
upstream-b7da0d294465d5ab8d923f3b8265ece0a5847ac3.zip
ath79: add support for Ubiquiti UniFi AP Pro
This adds support for the Ubiquiti UniFi AP Pro to the ath79 target. The device was previously supported on the now removed ar71xx target. SoC Atheros AR9344 WiFi Atheros AR9344 & Atheros AR9280 ETH Atheros AR8327 RAM 128M DDR2 FLASH 16M SPI-NOR Installation ------------ Follow the Ubiquiti TFTP recovery procedure for this device. 1. Hold down the reset button while connecting power for 10 seconds. 2. Transfer the factory image via TFTP to the AP (192.168.1.20) 3. Wait 2 minutes for the AP to write the firmware to flash. The device will automatically reboot to OpenWrt. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index b945183776..6939edd25d 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -13,6 +13,14 @@ define Build/mkubntimage
-k $(IMAGE_KERNEL) -r $@ -o $@
endef
+define Build/mkubntimage2
+ -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
+ -p jffs2:0x50000:0xf60000:0:0:$@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
# all UBNT XM/WA devices expect the kernel image to have 1024k while flash, when
# booting the image, the size doesn't matter.
define Build/mkubntimage-split
@@ -369,3 +377,20 @@ define Device/ubnt_unifiac-pro
SUPPORTED_DEVICES += unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-pro
+
+define Device/ubnt_unifi-ap-pro
+ SOC := ar9344
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := UniFi AP Pro
+ UBNT_TYPE := BZ
+ UBNT_CHIP := ar934x
+ KERNEL_SIZE := 3072k
+ IMAGE_SIZE := 15744k
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
+ pad-rootfs | append-metadata | check-size
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
+ SUPPORTED_DEVICES += uap-pro
+endef
+TARGET_DEVICES += ubnt_unifi-ap-pro