aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-08-23 15:50:49 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-29 11:31:05 +0200
commit4e93d17f2a8d701349c1dabaab38c869a968e93c (patch)
tree5882933d5460d95310f821cdaf50ffae8a557658 /target/linux/ath79/image/generic-ubnt.mk
parent6cdd518eb14a66dbd9b09c10b6467a48fe5cf470 (diff)
downloadupstream-4e93d17f2a8d701349c1dabaab38c869a968e93c.tar.gz
upstream-4e93d17f2a8d701349c1dabaab38c869a968e93c.tar.bz2
upstream-4e93d17f2a8d701349c1dabaab38c869a968e93c.zip
ath79: image: append metadata to routerstations and ja76pf2 images
This target enforces metadata check so add the necessary information. It was previously removed because md5 sum check. When using these sysupgrade images on ar71xx target the check would complain about them not matching. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> (cherry picked from commit 077d06a1a5a23caae4d0c53afb60913955d2a3ea)
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index b189d66770..f9f74d0f51 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -205,7 +205,7 @@ define Device/ubnt_routerstation_common
IMAGE_SIZE := 16128k
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
# IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb