aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 15:42:48 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-28 13:25:30 +0100
commit47935940d67147e3ec8dbfcb56ae14f1235369c5 (patch)
tree60f14835ad8b01e1e1edf3112c694e3ef740c910 /target/linux/ath79/image/generic-ubnt.mk
parentda5b5ae9b9647f50853bff96309d1435cddcefce (diff)
downloadupstream-47935940d67147e3ec8dbfcb56ae14f1235369c5.tar.gz
upstream-47935940d67147e3ec8dbfcb56ae14f1235369c5.tar.bz2
upstream-47935940d67147e3ec8dbfcb56ae14f1235369c5.zip
ath79: fix SUPPORTED_DEVICES not matching ar71xx board names
Based on a script for comparison, this fixes (hopefully) all errors in SUPPORTED_DEVICES for ar71xx->ath79 upgrade. Devices where old string is removed as the device does not exist in ar71xx: - dlink_dir-859-a1 - tplink_archer-a7-v5 - tplink_cpe510-v3 [only in master] Devices where string is changed because it did not match the board name in ar71xx: - tplink_tl-mr3220-v1 - tplink_tl-mr3420-v1 - tplink_tl-wr2543-v1 - tplink_tl-wr741nd-v4 - tplink_tl-wr841-v7 - ubnt_unifiac-mesh - ubnt_unifiac-mesh-pro - ubnt_unifiac-pro For this device, the correct string could not be found, but we could not determine the correct one. Thus, the string is removed for now: - tplink_tl-wr740n-v4 The script for checking this is quite simple (note that newer entries, i.e. ath79->ath79 upgrade, are displayed as missing): newpath=target/linux/ath79/image/ oldpath=target/linux/ar71xx/base-files/lib/ar71xx.sh for s in $(grep -roh "SUPPORTED_DEVICES.*" $newpath | sed 's/SUPPORTED_DEVICES *.= *//'); do found="Missing" grep -q -r "\"$s\"" $oldpath && found="Found" echo "$s: $found." done The errors might be filtered by appending 'grep "Missing"' to the script. Fixes: FS#2751 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 07ce940b77e6aceb095b0a16dda41e190dfc5b87)
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 8bc4523f46..12988d62e6 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -192,14 +192,14 @@ TARGET_DEVICES += ubnt_unifiac-lr
define Device/ubnt_unifiac-mesh
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh
- SUPPORTED_DEVICES += ubnt-unifiac-mesh
+ SUPPORTED_DEVICES += unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-mesh
define Device/ubnt_unifiac-mesh-pro
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh Pro
- SUPPORTED_DEVICES += ubnt-unifiac-mesh-pro
+ SUPPORTED_DEVICES += unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-mesh-pro
@@ -207,7 +207,7 @@ define Device/ubnt_unifiac-pro
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Pro
DEVICE_PACKAGES += kmod-usb-core kmod-usb2
- SUPPORTED_DEVICES += ubnt-unifiac-pro
+ SUPPORTED_DEVICES += unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-pro