aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-05-07 21:09:44 +0200
committerMathias Kresin <dev@kresin.me>2018-05-17 07:40:19 +0200
commitf77db1a59036d896139e6cddcdb62bf38f2f9ff6 (patch)
tree34a92eb4c34371b03e8ea4fb14433d697eb1ea5e /target/linux/ath79/image/generic-tp-link.mk
parentcfe442c5033d3fe626bb54391ecb0fc25c2f5049 (diff)
downloadupstream-f77db1a59036d896139e6cddcdb62bf38f2f9ff6.tar.gz
upstream-f77db1a59036d896139e6cddcdb62bf38f2f9ff6.tar.bz2
upstream-f77db1a59036d896139e6cddcdb62bf38f2f9ff6.zip
ath79: cleanup image build code
Remove recipes for not yet migrated boards. Drop variables which aren't required due to the switch to devicetree like boardname. Drop the legacy image build code. Boards added to this target shouldn't use the legacy image build code anyway. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk75
1 files changed, 75 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
new file mode 100644
index 0000000000..c7d44305cc
--- /dev/null
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -0,0 +1,75 @@
+DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME
+
+# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/mktplinkfw
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -m $(TPLINK_HEADER_VERSION) \
+ -k $(IMAGE_KERNEL) \
+ -r $@ \
+ -o $@.new \
+ -j -X 0x40000 \
+ -a $(call rootfs_align,$(FILESYSTEM)) \
+ $(wordlist 2,$(words $(1)),$(1)) \
+ $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
+endef
+
+# mktplinkfw-combined
+#
+# -c combined image
+define Build/mktplinkfw-combined
+ $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $(1) \
+ -m $(TPLINK_HEADER_VERSION) \
+ -k $@ \
+ -o $@.new \
+ -s -S \
+ -c
+ @mv $@.new $@
+endef
+
+
+define Device/tplink
+ TPLINK_HWREV := 0x1
+ TPLINK_HEADER_VERSION := 1
+ LOADER_TYPE := gz
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
+endef
+
+define Device/tplink-nolzma
+ $(Device/tplink)
+ LOADER_FLASH_OFFS := 0x22000
+ COMPILE := loader-$(1).gz
+ COMPILE/loader-$(1).gz := loader-okli-compile
+ KERNEL:= kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1)
+ KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs.bin.lzma | loader-kernel-cmdline | mktplinkfw-combined
+endef
+
+define Device/tplink-4m
+ $(Device/tplink-nolzma)
+ TPLINK_FLASHLAYOUT := 4M
+ IMAGE_SIZE := 3904k
+endef
+
+define Device/tplink-8m
+ $(Device/tplink-nolzma)
+ TPLINK_FLASHLAYOUT := 8M
+ IMAGE_SIZE := 7936k
+endef
+
+define Device/tl_wr1043nd_v1
+ $(Device/tplink-8m)
+ ATH_SOC := ar9132
+ DEVICE_TITLE := TP-LINK TL-WR1043N/ND v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x10430001
+endef
+#TARGET_DEVICES += tl_wr1043nd_v1