aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-09 12:49:17 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-13 20:43:15 +0200
commit7ef7dbaf7057da37afeefa3753bc4d0f0453e51f (patch)
treea763282c8ae1f546776b0d2643e61b20e3f95cd3 /target/linux/ath79/image/generic-tp-link.mk
parent488da882f5102e4283b4864e6180c2c7fb8f494a (diff)
downloadupstream-7ef7dbaf7057da37afeefa3753bc4d0f0453e51f.tar.gz
upstream-7ef7dbaf7057da37afeefa3753bc4d0f0453e51f.tar.bz2
upstream-7ef7dbaf7057da37afeefa3753bc4d0f0453e51f.zip
ath79: add support for TP-Link TL-WPA8630 v1
This ports the TP-Link TL-WPA8630 v1 from ar71xx to ath79. Specifications: SoC: QCA9563 CPU: 750 MHz Flash/RAM: 8 / 128 MiB Ethernet: 3x 1G ports (QCA8337 switch) WLAN: 2.4 GHz b/g/n, 5 GHz a/n/ac (ath10k) Buttons, LEDs and network setup appear to be almost identical to the v2 revision. Powerline interface is connected to switch port 5 (Label LAN4). Installation: No "fresh" device was available for testing the factory image. It is not known whether flashing via OEM firmware GUI is possible or not. A discussion from 2018 [1] about that indicates a few adjustments are necessary, but it is not clear whether those are already implemented with the TPLINK_HEADER_VERSION = 2 or not. Note that for the TL-WPA8630P v1, the TPLINK_HWID needs to be changed to 0x86310001 to allow factory flashing. [1] https://forum.openwrt.org/t/solved-tl-wpa8630p-lede-does-not-install/8161/27 Recovery: Recovery is only possible via serial. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index c2cda6b3df..fdc94b738a 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -500,6 +500,17 @@ define Device/tplink_tl-wdr4900-v2
endef
TARGET_DEVICES += tplink_tl-wdr4900-v2
+define Device/tplink_tl-wpa8630-v1
+ $(Device/tplink-8mlzma)
+ SOC := qca9563
+ DEVICE_MODEL := TL-WPA8630
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_HWID := 0x86300001
+ SUPPORTED_DEVICES += tl-wpa8630
+endef
+TARGET_DEVICES += tplink_tl-wpa8630-v1
+
define Device/tplink_tl-wpa8630p-v2
$(Device/tplink-safeloader)
SOC := qca9563