aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorSibren Vasse <github@sibrenvasse.nl>2018-06-26 07:25:33 +0200
committerJohn Crispin <john@phrozen.org>2018-06-26 08:57:26 +0200
commitba74b45476ab1fe36f8449b18501ba5d2c01cf8c (patch)
tree9c886cda6f584d3a8a3bec93b6a81bb59ce3ee59 /target/linux/ath79/image/generic-tp-link.mk
parent2a7e03af37d1112c2c2f6b6c80283d4d49407889 (diff)
downloadupstream-ba74b45476ab1fe36f8449b18501ba5d2c01cf8c.tar.gz
upstream-ba74b45476ab1fe36f8449b18501ba5d2c01cf8c.tar.bz2
upstream-ba74b45476ab1fe36f8449b18501ba5d2c01cf8c.zip
ath79: add support for TP-Link Archer c7 v2
Signed-off-by: Sibren Vasse <github@sibrenvasse.nl>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index accaf3b68f..8cfbcd3a67 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,5 +1,18 @@
include ./common-tp-link.mk
+define Device/tl-archer-c7-v2
+ $(Device/tplink-16mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-LINK Archer C7 v2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
+ TPLINK_HWID := 0xc7000002
+ SUPPORTED_DEVICES := tplink,tl-archer-c7-v2
+ IMAGES := sysupgrade.bin factory.bin factory-us.bin factory-eu.bin
+ IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+ IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+endef
+TARGET_DEVICES += tl-archer-c7-v2
+
define Device/tl-wdr3600
$(Device/tplink-8mlzma)
ATH_SOC := ar9344