aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-10-31 20:19:49 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit946ffe470d923fdde53db68592437194e0c276fc (patch)
tree2c58bfacae446fcb27ef3ac05d68254dab0c6b68 /target/linux/ath79/image/generic-tp-link.mk
parent89eb1a6d7250c33ff5b43f4af3c0c78ffd3d8eb9 (diff)
downloadupstream-946ffe470d923fdde53db68592437194e0c276fc.tar.gz
upstream-946ffe470d923fdde53db68592437194e0c276fc.tar.bz2
upstream-946ffe470d923fdde53db68592437194e0c276fc.zip
ath79: add support for Archer C58/C59 v1
This commit adds support for the Archer C58 v1 and C59 v1, previously supported in the ar71xx target. CPU: Qualcomm QCA9561 RAM: 64M (C58) / 128M (C59) FLASH: 8M (C58) / 16M (C59) WiFi: QCA9561 bgn 3x3:3 QCA9888 nac 2x2:2 LED: Power, WiFi 2.4, WiFi 5, WAN green, WAN amber, LAN, WPS Only C59: USB BTN: WPS, WiFi, Reset Installation ------------ Via Web-UI: Update factory image via Web-UI. Via TFTP: Rename factory image to "tp_recovery.bin" and place it in the root-dir of your tftp server. Configure to listen on 192.168.0.66. Power up the router while holding down the reset-button. The router will flash itself and reboot. Note: For TFTP, you might need a switch between router and computer, as link establishment might take to long. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index d65e29e72a..c89198621e 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,5 +1,27 @@
include ./common-tp-link.mk
+define Device/tplink_archer-c58-v1
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 7936k
+ DEVICE_TITLE := TP-LINK Archer C58 v1
+ TPLINK_BOARD_ID := ARCHER-C58-V1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c58-v1
+endef
+TARGET_DEVICES += tplink_archer-c58-v1
+
+define Device/tplink_archer-c59-v1
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 14528k
+ DEVICE_TITLE := TP-LINK Archer C59 v1
+ TPLINK_BOARD_ID := ARCHER-C59-V1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c59-v1
+endef
+TARGET_DEVICES += tplink_archer-c59-v1
+
define Device/tplink_archer-c7-v1
$(Device/tplink-8mlzma)
ATH_SOC := qca9558