aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-06-21 01:02:10 +0300
committerJohn Crispin <john@phrozen.org>2018-06-26 08:57:26 +0200
commit2a7e03af37d1112c2c2f6b6c80283d4d49407889 (patch)
tree6a93d85715b63894d1dcad4012e9335e54efbd74 /target/linux/ath79/image/generic-tp-link.mk
parentd375d5fafefb4de453ee36108b64f8df49aa2bec (diff)
downloadupstream-2a7e03af37d1112c2c2f6b6c80283d4d49407889.tar.gz
upstream-2a7e03af37d1112c2c2f6b6c80283d4d49407889.tar.bz2
upstream-2a7e03af37d1112c2c2f6b6c80283d4d49407889.zip
ath79: add tl-wr2543-v1 support
to switch between wlan leds we need a userspace implementation Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 467e2c4c42..accaf3b68f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -62,3 +62,16 @@ define Device/tl-wr1043nd-v4
SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
endef
TARGET_DEVICES += tl-wr1043nd-v4
+
+define Device/tl-wr2543-v1
+ $(Device/tplink-8mlzma)
+ ATH_SOC := ar7242
+ DEVICE_TITLE := TP-LINK TL-WR2543N/ND v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x25430001
+ IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade -v 3.13.99 | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := append-rootfs | mktplinkfw factory -v 3.13.99
+ SUPPORTED_DEVICES := tplink,tl-wr2543-v1 tl-wr2543-v1
+endef
+TARGET_DEVICES += tl-wr2543-v1