aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2018-10-07 12:21:45 +0200
committerMathias Kresin <dev@kresin.me>2018-10-07 15:44:19 +0200
commitadbd9d1f1f07f77b0f511027c1cfea87cefe47be (patch)
tree20ac803227cdf236c23bef962aabac566b3352a4 /target/linux/ath79/image/generic-tp-link.mk
parentebd57de1f9894a91991fe19f200dba7b1104390c (diff)
downloadupstream-adbd9d1f1f07f77b0f511027c1cfea87cefe47be.tar.gz
upstream-adbd9d1f1f07f77b0f511027c1cfea87cefe47be.tar.bz2
upstream-adbd9d1f1f07f77b0f511027c1cfea87cefe47be.zip
ath79: Add support for TP-Link TL-WR842N-v2
This PR adds support for TP-Link TL-WR842N-v2 router which is supported by ar71xx to ath79. This is a low cost model with following specs: CPU: Atheros AR9341 SoC RAM: 32 MB DDR1 Flash: 8 MB NOR SPI Switch: Internal AR9341 5 port 10/100 Mbit Ports: 5x 10/100 Mbit(1x WAN, 4x LAN) USB: 1x USB2.0 WLAN: 2.4 GHZ AR9341 Installation: Simply flash the factory image through stock firmware WEB UI. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index a9485c457e..d65e29e72a 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -77,6 +77,16 @@ define Device/tplink_tl-wr1043nd-v1
endef
TARGET_DEVICES += tplink_tl-wr1043nd-v1
+define Device/tplink_tl-wr842n-v2
+ $(Device/tplink-8mlzma)
+ ATH_SOC := ar9341
+ DEVICE_TITLE := TP-LINK TL-WR842N/ND v2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x8420002
+ SUPPORTED_DEVICES += tl-wr842n-v2
+endef
+TARGET_DEVICES += tplink_tl-wr842n-v2
+
define Device/tplink_tl-wr1043nd-v2
$(Device/tplink-8mlzma)
ATH_SOC := qca9558