aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorTOCK Chiu <tock.chiu@gmail.com>2018-12-24 10:36:59 +0800
committerChristian Lamparter <chunkeey@gmail.com>2018-12-27 14:06:38 +0100
commit8471944325db80ca37f7c756130070d0add58ff6 (patch)
tree96adc0822f214a551a1f7123767d805062b6e0f8 /target/linux/ath79/image/generic-tp-link.mk
parent3bb44f42990a75e66972016cde75bed6a3f09ef9 (diff)
downloadupstream-8471944325db80ca37f7c756130070d0add58ff6.tar.gz
upstream-8471944325db80ca37f7c756130070d0add58ff6.tar.bz2
upstream-8471944325db80ca37f7c756130070d0add58ff6.zip
ath79: add support for TP-Link Archer C7 v5
This commit adds support for TP-Link Archer C7 v5, leveraging most effort from commit ea9baee and 1e4ee63. Archer C7 v5 is identical to Archer A7 v5 but with a different flash layout. Specification: - QCA9563 SoC (750 MHz) - 128 MiB of RAM (DDR2) - 16 MiB of flash (SPI) - 5x 1 Gbps Ethernet (1x WAN + 4x LAN) - 2.4GHz (bgn) SoC internal + 5GHz (ac) QCA9880 - 10x LED, 2x button - UART header on PCB Flash instructions: 1. Upload openwrt-ath79-generic-tplink_archer-c7-v5-squashfs-factory.bin via web interface. Flash instructions using TFTP recovery: 1. Plug PC to one of the LAN ports 2. Set PC to fixed IP address 192.168.0.66 3. Rename the factory image to ArcherC7v5_tp_recovery.bin and place it in TFTP root directory 4. Turn on the router with the reset button pressed for about 15 secs 5. Release the button and wait about 150 secs to complete flashing Signed-off-by: TOCK Chiu <tock.chiu@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 2a883b253a..0fca5cf679 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -55,6 +55,18 @@ define Device/tplink_archer-c7-v2
endef
TARGET_DEVICES += tplink_archer-c7-v2
+define Device/tplink_archer-c7-v5
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 15360k
+ DEVICE_TITLE := TP-LINK Archer C7 v5
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := ARCHER-C7-V5
+ BOARDNAME := ARCHER-C7-V5
+ SUPPORTED_DEVICES += archer-c7-v5
+endef
+TARGET_DEVICES += tplink_archer-c7-v5
+
define Device/tplink_re450-v2
$(Device/tplink)
ATH_SOC := qca9563