aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAndrew Cameron <apcameron@softhome.net>2019-01-14 20:14:54 -0600
committerChristian Lamparter <chunkeey@gmail.com>2019-06-24 20:22:24 +0200
commite15049c88b917d1f9f75ed095f59f1dc6d69501c (patch)
tree180de81bc9ad2ebe99b56bbfdbaad5f5db6cb751 /target/linux/ath79/image/generic-tp-link.mk
parent8a5a01a67769f3822e365342d706b3cb57ef97f3 (diff)
downloadupstream-e15049c88b917d1f9f75ed095f59f1dc6d69501c.tar.gz
upstream-e15049c88b917d1f9f75ed095f59f1dc6d69501c.tar.bz2
upstream-e15049c88b917d1f9f75ed095f59f1dc6d69501c.zip
ath79: add support for TP-Link CPE610-v1
TP-Link CPE610-v1 is an outdoor wireless CPE for 5 GHz with one Ethernet port based on Atheros AR9344 Specifications: - Based on the same underlying hardware as the TP-Link CPE510 - Power, LAN, WLAN5G green LEDs - 23dBi high-gain directional 2×2 MIMO antenna and a dedicated metal reflector Flashing instructions: Flash factory image through stock firmware WEB UI or through TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 Signed-off-by: Andrew Cameron <apcameron@softhome.net>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 4757df49c6..73275ccf35 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -146,6 +146,17 @@ define Device/tplink_cpe210-v3
endef
TARGET_DEVICES += tplink_cpe210-v3
+define Device/tplink_cpe610-v1
+ $(Device/tplink-safeloader)
+ ATH_SOC := ar9344
+ IMAGE_SIZE := 7680k
+ DEVICE_TITLE := TP-Link CPE610 v1
+ TPLINK_BOARD_ID := CPE610V1
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
+endef
+TARGET_DEVICES += tplink_cpe610-v1
+
define Device/tplink_archer-d50-v1
ATH_SOC := qca9531
DEVICE_TITLE := TP-Link Archer D50 v1