aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAndrew Cameron <apcameron@softhome.net>2019-10-25 20:29:36 -0500
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-06 13:37:40 +0100
commitbae0d47f2e36376d2876bc4d5557e3e11f80f2fb (patch)
treee93c9fcf7d01d5a80afde9dcdfd8c94ff5cf9192 /target/linux/ath79/image/generic-tp-link.mk
parentd2b9333ea90ed89069879b4a676211c72c859f9b (diff)
downloadupstream-bae0d47f2e36376d2876bc4d5557e3e11f80f2fb.tar.gz
upstream-bae0d47f2e36376d2876bc4d5557e3e11f80f2fb.tar.bz2
upstream-bae0d47f2e36376d2876bc4d5557e3e11f80f2fb.zip
ath79: add support for the TP-LINK CPE220 V3
This adds support for a popular low-cost 2.4GHz N based AP Specifications: SoC: Qualcomm Atheros QCA9533 (650MHz) RAM: 64MB Storage: 8 MB SPI NOR Wireless: 2.4GHz N based built into SoC 2x2 Ethernet: 2x 100/10 Mbps, integrated into SoC Installation: Flash factory image through stock firmware WEB UI or through TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 This also applies some minor changes to the common DTSI: - use &wmac for label-mac-device, as this one is actually set up in common DTSI - move &eth0 to parent DTSI - fix several leading spaces, added/removed newlines Signed-off-by: Andrew Cameron <apcameron@softhome.net> [DTS style fixes/improvements, updated commit message/title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 69cb1719e6..a2b112a5ec 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -240,6 +240,18 @@ define Device/tplink_cpe220-v2
endef
TARGET_DEVICES += tplink_cpe220-v2
+define Device/tplink_cpe220-v3
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 7680k
+ DEVICE_MODEL := CPE220
+ DEVICE_VARIANT := v3
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE220V3
+ LOADER_TYPE := elf
+endef
+TARGET_DEVICES += tplink_cpe220-v3
+
define Device/tplink_cpe510-v1
$(Device/tplink-loader-okli)
ATH_SOC := ar9344