aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-20 13:03:43 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-07 18:04:03 +0200
commit854ab1b0453d49e68e51395833ef0933a51c471e (patch)
treea87590f3caeedd9ef3220f0b92c05a7f36df542b /target/linux/ath79/image/generic-tp-link.mk
parent0104eed1e5ca93a1c912e2d9b70e800b8d3099ad (diff)
downloadupstream-854ab1b0453d49e68e51395833ef0933a51c471e.tar.gz
upstream-854ab1b0453d49e68e51395833ef0933a51c471e.tar.bz2
upstream-854ab1b0453d49e68e51395833ef0933a51c471e.zip
ath79: add support for TP-Link CPE220 v2
This seems to be identical to CPE210 v1 despite having removable antennas. Specifications: * SoC: Qualcomm Atheros AR9344 (560 MHz) * RAM: 64MB * Storage: 8 MB * Wireless: 2.4GHz N based built into SoC 2x2 * Ethernet: 2x 100/10 Mbps, integrated into SoC, 24V POE IN Installation: Flash factory image through stock firmware WEB UI or through TFTP: To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP address:192.168.0.254 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index ffbdfbc14f..71ea0acddf 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -195,6 +195,17 @@ define Device/tplink_cpe210-v3
endef
TARGET_DEVICES += tplink_cpe210-v3
+define Device/tplink_cpe220-v2
+ $(Device/tplink-loader-okli)
+ ATH_SOC := ar9344
+ IMAGE_SIZE := 7680k
+ DEVICE_MODEL := CPE220
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE220V2
+endef
+TARGET_DEVICES += tplink_cpe220-v2
+
define Device/tplink_cpe510-v1
$(Device/tplink-loader-okli)
ATH_SOC := ar9344