aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-06-16 13:37:55 +0300
committerJohn Crispin <john@phrozen.org>2018-06-18 18:21:20 +0200
commit71ae0792bad1b0eeb476513e15b326409f15ccb0 (patch)
tree6c5b440e0ae27c02c0250a165e734f10827137a6 /target/linux/ath79/image/generic-tp-link.mk
parentcad843e1f57790a08dd4804011b6cd3a4796786b (diff)
downloadupstream-71ae0792bad1b0eeb476513e15b326409f15ccb0.tar.gz
upstream-71ae0792bad1b0eeb476513e15b326409f15ccb0.tar.bz2
upstream-71ae0792bad1b0eeb476513e15b326409f15ccb0.zip
ath79: add tl-wr1043nd-v4 support everything is working
tplink-safeloader: resize kernel partition kernel 4.14 is much bigger, resize the partition Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk36
1 files changed, 25 insertions, 11 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 0b4659abea..c946970818 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,16 +1,5 @@
include ./common-tp-link.mk
-
-define Device/tl-wr1043nd-v1
- $(Device/tplink-8m)
- ATH_SOC := ar9132
- DEVICE_TITLE := TP-LINK TL-WR1043N/ND v1
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
- TPLINK_HWID := 0x10430001
- SUPPORTED_DEVICES := tplink,tl-wr1043nd-v1 tl-wr1043nd
-endef
-TARGET_DEVICES += tl-wr1043nd-v1
-
define Device/tl-wdr3600
$(Device/tplink-8mlzma)
ATH_SOC := ar9344
@@ -28,3 +17,28 @@ define Device/tl-wdr4300
SUPPORTED_DEVICES := tplink,tl-wdr4300 tl-wdr4300
endef
TARGET_DEVICES += tl-wdr4300
+
+define Device/tl-wr1043nd-v1
+ $(Device/tplink-8m)
+ ATH_SOC := ar9132
+ DEVICE_TITLE := TP-LINK TL-WR1043N/ND v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x10430001
+ SUPPORTED_DEVICES := tplink,tl-wr1043nd-v1 tl-wr1043nd
+endef
+TARGET_DEVICES += tl-wr1043nd-v1
+
+define Device/tl-wr1043nd-v4
+ $(Device/tplink)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 15552k
+ DEVICE_TITLE := TP-LINK TL-WR1043N/ND v4
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x10430004
+ TPLINK_BOARD_ID := TLWR1043NDV4
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+ SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
+endef
+TARGET_DEVICES += tl-wr1043nd-v4