aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorGeorgi Vlaev <georgi.vlaev@gmail.com>2018-12-28 10:24:01 +0200
committerMathias Kresin <dev@kresin.me>2018-12-31 16:25:11 +0100
commitd03aae1a09fce5a5d5747855bc07ee1f54388e03 (patch)
tree36f9d5737ced8470a393b9ef7760433b857ca19b /target/linux/ath79/image/generic-tp-link.mk
parent9ebb44aef4db8f423f7bf1fd2436906b2eafb570 (diff)
downloadupstream-d03aae1a09fce5a5d5747855bc07ee1f54388e03.tar.gz
upstream-d03aae1a09fce5a5d5747855bc07ee1f54388e03.tar.bz2
upstream-d03aae1a09fce5a5d5747855bc07ee1f54388e03.zip
ath79: add support for TP-Link Archer C6 v2
This patch adds support for TP-Link Archer C6 v2 (EU) Hardware specification: - SOC: Qualcomm QCA9563 @ 775MHz - Flash: GigaDevice GD25Q64CSIG (8MiB) - RAM: Zentel A3R1GE40JBF (128 MiB DDR2) - Ethernet: Qualcomm QCA8337N: 4x 1Gbps LAN + 1x 1Gbps WAN - Wireless: - 2.4GHz (bgn) QCA9563 integrated (3x3) - 5GHz (ac) Qualcomm QCA9886 (2x2) - Button: 1x power, 1x reset, 1x wps - LED: 6x LEDs: power, wlan2g, wlan5g, lan, wan, wps - UART: There's no UART header on the board Flash instructions: Upload openwrt-ath79-generic-tplink_archer-c6-v2-squashfs-factory.bin via the router Web interface. Flash instruction using tftp recovery: 1. Connect the computer to one of the LAN ports of the router 2. Set the computer IP to 192.168.0.66 3. Start a tftp server with the OpenWrt factory image in the tftp root directory renamed to ArcherC6v2_tp_recovery.bin. 4. Connect power cable to router, press and hold the reset button and turn the router on 5. Keep the reset button pressed until the WPS LED lights up 6. Wait ~150 seconds to complete flashing According to the GPL source the non-EU variant has different GPIOs assigned to some of the LEDs and buttons. The flash layout might be different as well. The wikidevi entry for Archer A6/C6 assumes they are identical. Signed-off-by: Georgi Vlaev <georgi.vlaev@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 093ac7293d..be755c7ec0 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -34,6 +34,16 @@ define Device/tplink_archer-c59-v1
endef
TARGET_DEVICES += tplink_archer-c59-v1
+define Device/tplink_archer-c6-v2
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-LINK Archer C6 v2
+ TPLINK_BOARD_ID := ARCHER-C6-V2
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += tplink_archer-c6-v2
+
define Device/tplink_archer-c7-v1
$(Device/tplink-8mlzma)
ATH_SOC := qca9558