aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-05-05 18:36:43 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-26 17:01:20 +0100
commit70233e3afe409b3de9963db0b906bee97c771543 (patch)
tree9c8897cd7cd68fdfde8a23a42a51b6f1f87b0fb0 /target/linux/ath79/image/generic-tp-link.mk
parenta2d9de21b841ab641c81cf3f6f9eb53e7bbf4a6b (diff)
downloadupstream-70233e3afe409b3de9963db0b906bee97c771543.tar.gz
upstream-70233e3afe409b3de9963db0b906bee97c771543.tar.bz2
upstream-70233e3afe409b3de9963db0b906bee97c771543.zip
ath79: Add support for TP-Link Archer C60 v1
TP-Link Archer C60v1 is a dual-band AC1350 router, based on Qualcomm/Atheros QCA9561+QCA9886. Specification: - 775/650/258 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 2T2R 5 GHz - 5x 10/100 Mbps Ethernet - 7x LED, 2x button - UART header on PCB Flash instruction (WebUI): Download *-factory.bin image and upload it via the firmwary upgrade function of the stock firmware WebUI. Flash instruction (TFTP): 1. Set PC to fixed ip address 192.168.0.66 2. Download *-factory.bin image and rename it to tp_recovery.bin 3. Start a tftp server with the file tp_recovery.bin in its root directory 4. Turn off the router 5. Press and hold Reset button 6. Turn on router with the reset button pressed and wait ~15 seconds 7. Release the reset button and after a short time the firmware should be transferred from the tftp server 8. Wait ~30 second to complete recovery. Flash instruction under U-Boot, using UART: 1. tftp 0x81000000 ...-sysupgrade.bin 2. erase 0x9f020000 +$filesize 3. cp.b $fileaddr 0x9f020000 $filesize 4. reset Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 6d313da6dc5f655d92aa86e2ec42ecfcf763df3d)
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index b57fc0a57f..64c79d2f04 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -55,6 +55,17 @@ define Device/tplink_archer-c59-v1
endef
TARGET_DEVICES += tplink_archer-c59-v1
+define Device/tplink_archer-c60-v1
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9561
+ IMAGE_SIZE := 7936k
+ DEVICE_TITLE := TP-Link Archer C60 v1
+ TPLINK_BOARD_ID := ARCHER-C60-V1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ SUPPORTED_DEVICES += archer-c60-v1
+endef
+TARGET_DEVICES += tplink_archer-c60-v1
+
define Device/tplink_archer-c6-v2
$(Device/tplink-safeloader-uimage)
ATH_SOC := qca9563