aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-08-17 18:36:32 +0200
committerMathias Kresin <dev@kresin.me>2018-08-19 18:48:43 +0200
commit1c6e0f57a791880d7d204000bf4e095c13c5725a (patch)
tree5c7bb6f19c96e131f68c4de9d44dc22f4d592d95 /target/linux/ath79/image/generic-tp-link.mk
parentd1ea8ac3b476e1e552f42dbf1042b521c57a0df4 (diff)
downloadupstream-1c6e0f57a791880d7d204000bf4e095c13c5725a.tar.gz
upstream-1c6e0f57a791880d7d204000bf4e095c13c5725a.tar.bz2
upstream-1c6e0f57a791880d7d204000bf4e095c13c5725a.zip
ath79: add support for TP-Link Archer C7 v1
TP-Link Archer C7 v1 is a dual band router based on Qualcomm/Atheros QCA9558 + QCA9880. Specification: - 720 MHz CPU - 128 MB of RAM (Various chips) - 8 MB of FLASH (Various chips) - SoC QCA9558 integrated 3T3R 2.4 GHz Wi-Fi - minipcie slot with 3T3R 5 GHz QCA9880-AR1A (unsupported by ath10k!) - 5x 10/100/1000 Mbps Ethernet (AR8327N Switch) - 10x LEDs, 2x software buttons For further informwation on the device, visit the wiki: <https://openwrt.org/toh/tp-link/archer-c7-1750> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 4c85099a1a..926c3cb618 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,5 +1,14 @@
include ./common-tp-link.mk
+define Device/tplink_archer-c7-v1
+ $(Device/tplink-8mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-LINK Archer C7 v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
+ TPLINK_HWID := 0x75000001
+endef
+TARGET_DEVICES += tplink_archer-c7-v1
+
define Device/tplink_archer-c7-v2
$(Device/tplink-16mlzma)
ATH_SOC := qca9558