aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-09 12:29:28 +0800
committerMathias Kresin <dev@kresin.me>2018-08-11 21:36:27 +0200
commitd4e3a31f6ca797cb9f43a8f47fbff935ee3132ad (patch)
treeb1eb01ee56356e4a491467807af37d62c3bee6e2 /target/linux/ath79/image/generic-tp-link.mk
parent3493c1cf41ecaa2f87394059a26578f723109a15 (diff)
downloadupstream-d4e3a31f6ca797cb9f43a8f47fbff935ee3132ad.tar.gz
upstream-d4e3a31f6ca797cb9f43a8f47fbff935ee3132ad.tar.bz2
upstream-d4e3a31f6ca797cb9f43a8f47fbff935ee3132ad.zip
ath79: add support for TP-Link TL-WDR4900 v2
Specification: - SoC: Qualcomm Atheros QCA9558 - Flash: 8 MB - RAM: 128 MB - Ethernet: AR8327N with 5 GE ports. - Wireless radio: QCA9558 for 2.4G and AR9580 for 5G. Flash instruction: Upload the generated factory firmware on web interface. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 623252ee7d..0f8bfff8ad 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -49,6 +49,15 @@ define Device/tplink_tl-wdr4300
endef
TARGET_DEVICES += tplink_tl-wdr4300
+define Device/tplink_tl-wdr4900-v2
+ $(Device/tplink-8mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-LINK TL-WDR4900 v2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x49000002
+endef
+TARGET_DEVICES += tplink_tl-wdr4900-v2
+
define Device/tplink_tl-wr1043nd-v1
$(Device/tplink-8m)
ATH_SOC := ar9132