aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-ubnt.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-06-07 15:58:27 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 17:09:54 +0200
commit5c142aad7bc018fe000789740a486c49973035b8 (patch)
tree0506a6f394f4fd5024a1182d17c008ed54291c35 /target/linux/ath79/image/common-ubnt.mk
parent4cca0947fff08716eb2190795d94072e3126f86b (diff)
downloadupstream-5c142aad7bc018fe000789740a486c49973035b8.tar.gz
upstream-5c142aad7bc018fe000789740a486c49973035b8.tar.bz2
upstream-5c142aad7bc018fe000789740a486c49973035b8.zip
ath79: switch some RedBoot based devices to OKLI loader
After the kernel has switched version to 5.10, JA76PF2 and RouterStations lost the capability to sysupgrade the OpenWrt version. The cause is the lack of porting the patches responsible for partial flash erase block writing and these boards FIS directory and RedBoot config partitions share the same erase block. Because of that the FIS directory can't be updated to accommodate kernel/rootfs partition size changes. This could be remedied by bootloader update, but it is very intrusive and could potentially lead to non-trivial recovery procedure, if something went wrong. The less difficult option is to use OpenWrt kernel loader, which will let us use static partition sizes and employ mtd splitter to dynamically adjust kernel and rootfs partition sizes. On sysupgrade from ath79 19.07 or 21.02 image, which still let to modify FIS directory, the loader will be written to kernel partition, while the kernel+rootfs to rootfs partition. The caveats are: * image format changes, no possible upgrade from ar71xx target images * downgrade to any older OpenWrt version will require TFTP recovery or usage of bootloader command line interface To downgrade to 19.07 or 21.02, or to upgrade if one is already on OpenWrt with kernel 5.10, for RouterStations use TFTP recovery procedure. For JA76PF2 use instructions from this commit message: commit 0cc87b3bacee ("ath79: image: disable sysupgrade images for routerstations and ja76pf2"), replacing kernel image with loader (loader.bin suffix) and rootfs image with firmware (firmware.bin suffix). Fixes: b10d6044599d ("kernel: add linux 5.10 support") Fixes: 15aa53d7ee65 ("ath79: switch to Kernel 5.10") Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> (mkubntimage was moved to generic-ubnt.mk) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/common-ubnt.mk')
-rw-r--r--target/linux/ath79/image/common-ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/common-ubnt.mk b/target/linux/ath79/image/common-ubnt.mk
index 625f0b4f3f..76d6de000b 100644
--- a/target/linux/ath79/image/common-ubnt.mk
+++ b/target/linux/ath79/image/common-ubnt.mk
@@ -10,7 +10,7 @@ UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
define Build/mkubntimage
-$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
-v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
- -k $(IMAGE_KERNEL) -r $@ -o $@
+ -k $(if $(1),$(1),$(IMAGE_KERNEL)) -r $@ -o $@
endef
define Build/mkubntimage2