aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-senao.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 16:07:44 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-02 21:26:12 +0200
commit2d977eb3d53a9fb442bc8847f41b88c5c4128c8a (patch)
treed4b86b58951e35544a8e5d40e92b26e45e5b1387 /target/linux/ath79/image/common-senao.mk
parent53d19bb8cf88483df4fe4557c90cb3d85d9dd086 (diff)
downloadupstream-2d977eb3d53a9fb442bc8847f41b88c5c4128c8a.tar.gz
upstream-2d977eb3d53a9fb442bc8847f41b88c5c4128c8a.tar.bz2
upstream-2d977eb3d53a9fb442bc8847f41b88c5c4128c8a.zip
ath79: add recipe for common setup with loader-okli-compile
These instructions are repeated for a few devices now, let's move them to shared definition so we do not repeat ourselves too often. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/common-senao.mk')
-rw-r--r--target/linux/ath79/image/common-senao.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/ath79/image/common-senao.mk b/target/linux/ath79/image/common-senao.mk
index 6784cf9aae..c9c14944c4 100644
--- a/target/linux/ath79/image/common-senao.mk
+++ b/target/linux/ath79/image/common-senao.mk
@@ -26,13 +26,9 @@ define Build/senao-tar-gz
endef
define Device/senao_loader_okli
+ $(Device/loader-okli-uimage)
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x73714f4b
LOADER_KERNEL_MAGIC := 0x73714f4b
- LOADER_TYPE := bin
- COMPILE := loader-$(1).bin loader-$(1).uImage
- COMPILE/loader-$(1).bin := loader-okli-compile
- COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | lzma | \
- uImage lzma
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
check-size | senao-tar-gz $$$$(SENAO_IMGNAME)