aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-netgear.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-25 20:29:12 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-29 12:08:16 +0200
commit01a3e891d745ea15b149483bde43d6dfe75cd1fa (patch)
tree672c8638f355319c2badfb3c899fc233bfd73b05 /target/linux/ath79/image/common-netgear.mk
parenta15ed964cfd09ded63c654738123d20d546c6d35 (diff)
downloadupstream-01a3e891d745ea15b149483bde43d6dfe75cd1fa.tar.gz
upstream-01a3e891d745ea15b149483bde43d6dfe75cd1fa.tar.bz2
upstream-01a3e891d745ea15b149483bde43d6dfe75cd1fa.zip
ath79: reorganize common image definitions for Netgear
Netgear currently has a special definition for tiny devices, which is only used by two devices. Despite, it sets ups the IMAGE/default definition individually for all devices, although there is actually only one exception. This merges the common parts into a single netgear_generic definition (in contrast to netgear_ath79_nand), and adjusts the individual definitions accordingly. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/common-netgear.mk')
-rw-r--r--target/linux/ath79/image/common-netgear.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
index 51808069e3..b41650c6e9 100644
--- a/target/linux/ath79/image/common-netgear.mk
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -33,10 +33,13 @@ define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef
-define Device/netgear_ath79
+define Device/netgear_generic
DEVICE_VENDOR := NETGEAR
KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
IMAGES += factory.img
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | \
+ append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
check-size
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | \