aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-07-04 14:23:03 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-15 15:22:07 +0200
commit8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca (patch)
tree578a60e19b1a5c6a4a669b019a30309592344cc9 /target/linux/ath79/image/Makefile
parent01b8cd32003408ba3aab7a48b0ffa90b5b720f0d (diff)
downloadupstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.tar.gz
upstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.tar.bz2
upstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.zip
ath79: switch some RedBoot based devices to OKLI loader
After the kernel has switched version to 5.10, JA76PF2 and RouterStations lost the capability to sysupgrade the OpenWrt version. The cause is the lack of porting the patches responsible for partial flash erase block writing and these boards FIS directory and RedBoot config partitions share the same erase block. Because of that the FIS directory can't be updated to accommodate kernel/rootfs partition size changes. This could be remedied by bootloader update, but it is very intrusive and could potentially lead to non-trivial recovery procedure, if something went wrong. The less difficult option is to use OpenWrt kernel loader, which will let us use static partition sizes and employ mtd splitter to dynamically adjust kernel and rootfs partition sizes. On sysupgrade from ath79 19.07 or 21.02 image, which still let to modify FIS directory, the loader will be written to kernel partition, while the kernel+rootfs to rootfs partition. The caveats are: * image format changes, no possible upgrade from ar71xx target images * downgrade to any older OpenWrt version will require TFTP recovery or usage of bootloader command line interface To downgrade to 19.07 or 21.02, or to upgrade if one is already on OpenWrt with kernel 5.10, for RouterStations use TFTP recovery procedure. For JA76PF2 use instructions from this commit message: commit 0cc87b3bacee ("ath79: image: disable sysupgrade images for routerstations and ja76pf2"), replacing kernel image with loader (loader.bin suffix) and rootfs image with firmware (firmware.bin suffix). Fixes: b10d6044599d ("kernel: add linux 5.10 support") Fixes: 15aa53d7ee65 ("ath79: switch to Kernel 5.10") Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> (mkubntimage was moved to generic-ubnt.mk) Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 5c142aad7bc018fe000789740a486c49973035b8)
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 768ec57044..32a4b2abed 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -8,14 +8,6 @@ DEVICE_VARS += LOADER_FLASH_MAX LOADER_KERNEL_MAGIC
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
-define Build/combined-image
- sh $(TOPDIR)/scripts/combined-image.sh \
- "$(IMAGE_KERNEL)" \
- "$@" \
- "$@.new"
- @mv $@.new $@
-endef
-
define Build/loader-common
rm -rf $@.src
$(MAKE) -C lzma-loader \