aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-06 10:20:11 +0200
committerJohn Crispin <john@phrozen.org>2018-05-07 08:06:51 +0200
commit53c474abbdfef8eb3499e2d10c9ad491788b8a72 (patch)
treeacd19415420664f59bc63c1ceb4ad37bb7323027 /target/linux/ath79/generic
parent3dc523f232ff01d31d59345f5fa6de508d5059ef (diff)
downloadupstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.gz
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.bz2
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.zip
ath79: add new OF only target for QCA MIPS silicon
This target aims to replace ar71xx mid-term. The big part that is still missing is making the MMIO/AHB wifi work using OF. NAND and mikrotik subtargets will follow. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath79/generic')
-rw-r--r--target/linux/ath79/generic/config-default16
-rw-r--r--target/linux/ath79/generic/profiles/00-default.mk16
-rw-r--r--target/linux/ath79/generic/target.mk8
3 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/ath79/generic/config-default b/target/linux/ath79/generic/config-default
new file mode 100644
index 0000000000..bbed97b6b5
--- /dev/null
+++ b/target/linux/ath79/generic/config-default
@@ -0,0 +1,16 @@
+CONFIG_BLK_MQ_PCI=y
+CONFIG_HW_HAS_PCI=y
+CONFIG_LEDS_RESET=y
+# CONFIG_MIPS_MACHINE is not set
+CONFIG_OF_ADDRESS_PCI=y
+CONFIG_OF_PCI=y
+CONFIG_OF_PCI_IRQ=y
+CONFIG_PCI=y
+CONFIG_PCI_AR71XX=y
+CONFIG_PCI_AR724X=y
+CONFIG_PCI_DISABLE_COMMON_QUIRKS=y
+CONFIG_PCI_DOMAINS=y
+CONFIG_PHY_AR7100_USB=y
+CONFIG_PHY_AR7200_USB=y
+# CONFIG_WIRELESS is not set
+# CONFIG_WLAN is not set
diff --git a/target/linux/ath79/generic/profiles/00-default.mk b/target/linux/ath79/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..83b39e4418
--- /dev/null
+++ b/target/linux/ath79/generic/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PRIORITY := 1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/generic/target.mk b/target/linux/ath79/generic/target.mk
new file mode 100644
index 0000000000..64eb205e4d
--- /dev/null
+++ b/target/linux/ath79/generic/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Generic
+FEATURES += squashfs
+
+define Target/Description
+ Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
+endef
+
+