aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2020-09-07 18:52:31 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-22 23:02:08 +0200
commit98eb95dd0018d4f21a5b86b323074d5854e1bde3 (patch)
treeb92b0eadee6b1143b1b9e4bf272b07dc6d27a64d /target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
parent61b49cd3f8587acddb12582fe7fc91a8f519cf4d (diff)
downloadupstream-98eb95dd0018d4f21a5b86b323074d5854e1bde3.tar.gz
upstream-98eb95dd0018d4f21a5b86b323074d5854e1bde3.tar.bz2
upstream-98eb95dd0018d4f21a5b86b323074d5854e1bde3.zip
ath79: add support for Atheros DB120 reference board
Atheros DB120 reference board. Specifications: SoC: QCA9344 DRAM: 128Mb DDR2 Flash: 8Mb SPI-NOR, 128Mb NAND flash Switch: 5x 10/100Mbps via AR8229 switch (integrated into SoC), 5x 10/100/1000Mbps via QCA8237 via RGMII WLAN: AR9300 (SoC, 2.4G+5G) + AR9340 (PCIe, 5G-only) USB: 1x 2.0 UART: standard QCA UART header JTAG: yes Button: 1x reset LEDs: a lot Slots: 2x mPCIe + 1x mini-PCI, but using them requires additional undocumented changes. Misc: The board allows to boot off NAND, and there is I2S audio support as well - also requiring additional undocumented changes. Installation: 1. Original bootloader Connect the board to ethernet Set up a server with an IP address of 192.168.1.10 Make the openwrt-ath79-generic-atheros_db120-squashfs-factory.bin available via TFTP tftpboot 0x80060000 openwrt-ath79-generic-atheros_db120-squashfs-factory.bin erase 0x9f050000 +$filesize cp.b $fileaddr 0x9f050000 $filesize 2. pepe2k's u-boot_mod Connect the board to ethernet Set up a server with an IP address of 192.168.1.10 Make the openwrt-ath79-generic-atheros_db120-squashfs-factory.bin available via TFTP, as "firmware.bin" run fw_upg Reboot the board. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> [explicit factory recipe in generic.mk, sorting in 10-ath9k-eeprom, convert to nvmem, use fwconcat* names in DTS, remove unneeded DT labels, remove redundant uart node] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom')
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom29
1 files changed, 15 insertions, 14 deletions
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 388f477856..3e02b066a9 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -72,6 +72,21 @@ case "$FIRMWARE" in
;;
"ath9k-eeprom-pci-0000:00:00.0.bin")
case $board in
+ atheros,db120|\
+ engenius,eap600|\
+ engenius,ecb600|\
+ mercury,mw4530r-v1|\
+ ocedo,raccoon|\
+ tplink,tl-wdr3500-v1|\
+ tplink,tl-wdr3600-v1|\
+ tplink,tl-wdr4300-v1|\
+ tplink,tl-wdr4300-v1-il|\
+ tplink,tl-wdr4310-v1|\
+ tplink,tl-wdr4900-v2|\
+ ubnt,unifi-ap-pro|\
+ winchannel,wb2000)
+ caldata_extract "art" 0x5000 0x440
+ ;;
avm,fritz300e)
caldata_extract_reverse "urloader" 0x1541 0x440
;;
@@ -88,20 +103,6 @@ case "$FIRMWARE" in
caldata_extract "art" 0x5000 0x440
ath9k_patch_mac $(macaddr_add $(mtd_get_mac_text "mac" 0x18) 1)
;;
- engenius,eap600|\
- engenius,ecb600|\
- mercury,mw4530r-v1|\
- ocedo,raccoon|\
- tplink,tl-wdr3500-v1|\
- tplink,tl-wdr3600-v1|\
- tplink,tl-wdr4300-v1|\
- tplink,tl-wdr4300-v1-il|\
- tplink,tl-wdr4310-v1|\
- tplink,tl-wdr4900-v2|\
- ubnt,unifi-ap-pro|\
- winchannel,wb2000)
- caldata_extract "art" 0x5000 0x440
- ;;
enterasys,ws-ap3705i)
caldata_extract "calibrate" 0x5000 0x440
ath9k_patch_mac $(mtd_get_mac_ascii u-boot-env0 RADIOADDR0)