aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-07-04 14:23:03 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-15 15:22:07 +0200
commit8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca (patch)
tree578a60e19b1a5c6a4a669b019a30309592344cc9 /target/linux/ath79/dts
parent01b8cd32003408ba3aab7a48b0ffa90b5b720f0d (diff)
downloadupstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.tar.gz
upstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.tar.bz2
upstream-8e09f9ffc3cc67d2e64984ad463ce677ae9d9cca.zip
ath79: switch some RedBoot based devices to OKLI loader
After the kernel has switched version to 5.10, JA76PF2 and RouterStations lost the capability to sysupgrade the OpenWrt version. The cause is the lack of porting the patches responsible for partial flash erase block writing and these boards FIS directory and RedBoot config partitions share the same erase block. Because of that the FIS directory can't be updated to accommodate kernel/rootfs partition size changes. This could be remedied by bootloader update, but it is very intrusive and could potentially lead to non-trivial recovery procedure, if something went wrong. The less difficult option is to use OpenWrt kernel loader, which will let us use static partition sizes and employ mtd splitter to dynamically adjust kernel and rootfs partition sizes. On sysupgrade from ath79 19.07 or 21.02 image, which still let to modify FIS directory, the loader will be written to kernel partition, while the kernel+rootfs to rootfs partition. The caveats are: * image format changes, no possible upgrade from ar71xx target images * downgrade to any older OpenWrt version will require TFTP recovery or usage of bootloader command line interface To downgrade to 19.07 or 21.02, or to upgrade if one is already on OpenWrt with kernel 5.10, for RouterStations use TFTP recovery procedure. For JA76PF2 use instructions from this commit message: commit 0cc87b3bacee ("ath79: image: disable sysupgrade images for routerstations and ja76pf2"), replacing kernel image with loader (loader.bin suffix) and rootfs image with firmware (firmware.bin suffix). Fixes: b10d6044599d ("kernel: add linux 5.10 support") Fixes: 15aa53d7ee65 ("ath79: switch to Kernel 5.10") Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> (mkubntimage was moved to generic-ubnt.mk) Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 5c142aad7bc018fe000789740a486c49973035b8)
Diffstat (limited to 'target/linux/ath79/dts')
-rw-r--r--target/linux/ath79/dts/ar7161_jjplus_ja76pf2.dts39
-rw-r--r--target/linux/ath79/dts/ar7161_ubnt_routerstation.dtsi35
2 files changed, 72 insertions, 2 deletions
diff --git a/target/linux/ath79/dts/ar7161_jjplus_ja76pf2.dts b/target/linux/ath79/dts/ar7161_jjplus_ja76pf2.dts
index 826b45ff51..7a8e2faa53 100644
--- a/target/linux/ath79/dts/ar7161_jjplus_ja76pf2.dts
+++ b/target/linux/ath79/dts/ar7161_jjplus_ja76pf2.dts
@@ -4,6 +4,7 @@
#include <dt-bindings/gpio/gpio.h>
#include <dt-bindings/input/input.h>
+#include <dt-bindings/mtd/partitions/uimage.h>
/ {
model = "jjPlus JA76PF2";
@@ -111,9 +112,45 @@
spi-max-frequency = <25000000>;
partitions {
+ compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;
- compatible = "ecoscentric,redboot-fis-partitions";
+
+ partition@0 {
+ label = "RedBoot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "loader";
+ reg = <0x040000 0x020000>;
+ };
+
+ partition@60000 {
+ label = "firmware";
+ reg = <0x060000 0xf80000>;
+ compatible = "openwrt,uimage", "denx,uimage";
+ openwrt,ih-magic = <IH_MAGIC_OKLI>;
+ };
+
+ partition@fe0000 {
+ label = "FIS directory";
+ reg = <0xfe0000 0x00f000>;
+ read-only;
+ };
+
+ partition@fef000 {
+ label = "RedBoot config";
+ reg = <0xfef000 0x001000>;
+ read-only;
+ };
+
+ partition@ff0000 {
+ label = "Atheros Board Data";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
};
};
};
diff --git a/target/linux/ath79/dts/ar7161_ubnt_routerstation.dtsi b/target/linux/ath79/dts/ar7161_ubnt_routerstation.dtsi
index 116bc9cfc2..172b0af1eb 100644
--- a/target/linux/ath79/dts/ar7161_ubnt_routerstation.dtsi
+++ b/target/linux/ath79/dts/ar7161_ubnt_routerstation.dtsi
@@ -4,6 +4,7 @@
#include <dt-bindings/gpio/gpio.h>
#include <dt-bindings/input/input.h>
+#include <dt-bindings/mtd/partitions/uimage.h>
/ {
aliases {
@@ -62,7 +63,39 @@
spi-max-frequency = <25000000>;
partitions {
- compatible = "ecoscentric,redboot-fis-partitions";
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "RedBoot";
+ reg = <0x000000 0x030000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "loader";
+ reg = <0x030000 0x020000>;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x050000 0xfa0000>;
+ compatible = "openwrt,uimage", "denx,uimage";
+ openwrt,ih-magic = <IH_MAGIC_OKLI>;
+ };
+
+ partition@ff0000 {
+ label = "FIS directory";
+ reg = <0xff0000 0x00f000>;
+ read-only;
+ };
+
+ partition@fff000 {
+ label = "RedBoot config";
+ reg = <0xfff000 0x001000>;
+ read-only;
+ };
};
};
};