aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi')
-rw-r--r--target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi204
1 files changed, 0 insertions, 204 deletions
diff --git a/target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi b/target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi
deleted file mode 100644
index 6c56306ad5..0000000000
--- a/target/linux/ath79/dts/qca9563_tl-wr1043n.dtsi
+++ /dev/null
@@ -1,204 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
-
-/ {
- chosen {
- bootargs = "console=ttyS0,115200n8";
- };
-
- aliases {
- led-status = &system;
- };
-
- gpio_leds: leds {
- compatible = "gpio-leds";
-
- system: system {
- label = "tp-link:green:system";
- gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "heartbeat";
- };
-
- wifi_green {
- label = "tp-link:green:wlan";
- gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy0tpt";
- };
-
- wifi_wps {
- label = "tp-link:green:wps";
- gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- wan {
- label = "tp-link:green:wan";
- gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- wan_fail {
- label = "tp-link:orange:wan";
- gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- lan1 {
- label = "tp-link:green:lan1";
- gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- lan2 {
- label = "tp-link:green:lan2";
- gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- lan3 {
- label = "tp-link:green:lan3";
- gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- lan4 {
- label = "tp-link:green:lan4";
- gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
- };
-
- keys {
- compatible = "gpio-keys";
- #address-cells = <1>;
- #size-cells = <0>;
-
- reset {
- label = "Reset button";
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- wifi {
- label = "RFKILL button";
- linux,code = <KEY_RFKILL>;
- gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-
- gpio-export {
- compatible = "gpio-export";
- #size-cells = <0>;
-
- gpio_usb_power {
- gpio-export,name = "tp-link:power:usb";
- gpio-export,output = <1>;
- gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&spi {
- status = "okay";
- num-cs = <1>;
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x000000 0x020000>;
- read-only;
- };
-
- partition@20000 {
- label = "firmware";
- reg = <0x020000 0xf30000>;
- };
-
- info: partition@f50000 {
- label = "product-info";
- reg = <0xf50000 0x020000>;
- read-only;
- };
-
- partition@f70000 {
- label = "config";
- reg = <0xf70000 0x050000>;
- read-only;
- };
-
- partition@fc0000 {
- label = "partition-table";
- reg = <0xfc0000 0x010000>;
- read-only;
- };
-
- partition@fd0000 {
- label = "logs";
- reg = <0xfd0000 0x020000>;
- read-only;
- };
-
- art: partition@ff0000 {
- label = "ART";
- reg = <0xff0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-&mdio0 {
- status = "okay";
-
- phy-mask = <0>;
- phy0: ethernet-phy@0 {
- reg = <0>;
- phy-mode = "sgmii";
-
- qca,ar8327-initvals = <
- 0x04 0x00080080 /* PORT0 PAD MODE CTRL */
- 0x7c 0x0000007e /* PORT0_STATUS */
- >;
- };
-};
-
-&eth0 {
- status = "okay";
-
- mtd-mac-address = <&info 0x8>;
- phy-mode = "sgmii";
- phy-handle = <&phy0>;
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&info 0x8>;
-};