aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/qca9563_tl-re450-v2.dts
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/qca9563_tl-re450-v2.dts
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/qca9563_tl-re450-v2.dts')
-rw-r--r--target/linux/ath79/dts/qca9563_tl-re450-v2.dts195
1 files changed, 0 insertions, 195 deletions
diff --git a/target/linux/ath79/dts/qca9563_tl-re450-v2.dts b/target/linux/ath79/dts/qca9563_tl-re450-v2.dts
deleted file mode 100644
index 646cdf2975..0000000000
--- a/target/linux/ath79/dts/qca9563_tl-re450-v2.dts
+++ /dev/null
@@ -1,195 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
-
-/ {
- compatible = "tplink,re450-v2", "qca,qca9563";
- model = "TP-Link RE450 v2";
-
- chosen {
- bootargs = "console=ttyS0,115200n8";
- };
-
- aliases {
- led-status = &system;
- mdio-gpio0 = &mdio2;
- };
-
- leds {
- compatible = "gpio-leds";
-
- system: power {
- label = "tp-link:blue:power";
- gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
- };
-
- wlan2g {
- label = "tp-link:blue:wlan2g";
- gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy1tpt";
- };
-
- wlan5g {
- label = "tp-link:blue:wlan5g";
- gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy0tpt";
- };
-
- lan_link {
- label = "tp-link:green:lan_link";
- gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- lan_data {
- label = "tp-link:green:lan_data";
- gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- wps_blue {
- label = "tp-link:blue:wps";
- gpios = <&gpio 17 GPIO_ACTIVE_HIGH>;
- default-state = "off";
- };
-
- wps_red {
- label = "tp-link:red:wps";
- gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
- default-state = "off";
- };
- };
-
- keys {
- compatible = "gpio-keys";
- #address-cells = <1>;
- #size-cells = <0>;
-
- reset {
- label = "Reset button";
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- power {
- label = "Power button";
- linux,code = <KEY_POWER>;
- gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- leds {
- label = "LED control button";
- linux,code = <BTN_0>;
- gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- wps {
- label = "WPS button";
- linux,code = <KEY_WPS_BUTTON>;
- gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-
- mdio2: mdio {
- compatible = "virtual,mdio-gpio";
-
- gpios = <&gpio 3 GPIO_ACTIVE_HIGH>, /* MDC */
- <&gpio 4 GPIO_ACTIVE_HIGH>; /* MDIO */
- #address-cells = <1>;
- #size-cells = <0>;
-
- phy0: ethernet-phy@4 {
- reg = <4>;
- device_type = "ethernet-phy";
- reset-gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&pcie {
- status = "okay";
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&spi {
- status = "okay";
- num-cs = <1>;
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x000000 0x020000>;
- read-only;
- };
-
- partition@20000 {
- label = "firmware";
- reg = <0x020000 0x5e0000>;
- };
-
- partition@600000 {
- label = "partition-table";
- reg = <0x600000 0x010000>;
- read-only;
- };
-
- info: partition@610000 {
- label = "product-info";
- reg = <0x610000 0x020000>;
- read-only;
- };
-
- partition@630000 {
- label = "config";
- reg = <0x630000 0x020000>;
- read-only;
- };
-
- art: partition@7f0000 {
- label = "art";
- reg = <0x7f0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-&eth0 {
- status = "okay";
- mtd-mac-address = <&info 0x8>;
- phy-handle = <&phy0>;
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&info 0x8>;
-};