aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-10-28 00:30:51 +0100
committerJohn Crispin <john@phrozen.org>2019-11-02 20:51:56 +0100
commit6d00e6fc7bc598daea83c5a5582daf3d081af87f (patch)
treed1115093d84fb36c6bc4827e4e1b45648bf25688 /target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts
parentcd87272eb241b1ea7955c1631ad2bb8d38e9fae9 (diff)
downloadupstream-6d00e6fc7bc598daea83c5a5582daf3d081af87f.tar.gz
upstream-6d00e6fc7bc598daea83c5a5582daf3d081af87f.tar.bz2
upstream-6d00e6fc7bc598daea83c5a5582daf3d081af87f.zip
ath79: fix several issues for ZyXEL NBG6716
This fixes several issues introduced with ZyXEL NBG6716 support: - Inhomogeneous indent - Wrong ath10k MAC patching function - Wrong brackets for pad-to in nand.mk - Add missing DEVICE_MODEL - Remove k2t.sh include (copy/paste leftover) Fixes: 99835e09992b ("ath79: add support for ZyXEL NBG6716") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts')
-rw-r--r--target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts b/target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts
index ea153d9f77..3e373928da 100644
--- a/target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts
+++ b/target/linux/ath79/dts/qca9558_zyxel_nbg6716.dts
@@ -76,21 +76,21 @@
debounce-interval = <60>;
};
- wifi_button {
- label = "WiFi button";
+ wifi_button {
+ label = "WiFi button";
linux,code = <KEY_RFKILL>;
gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
debounce-interval = <60>;
};
- usb1 {
+ usb1 {
label = "USB1 eject button";
gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
debounce-interval = <60>;
};
- usb2 {
- label = "USB2 eject button";
+ usb2 {
+ label = "USB2 eject button";
gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
debounce-interval = <60>;
};
@@ -105,7 +105,7 @@
};
&gpio {
- gpio_usb_power {
+ usb_power {
gpio-hog;
gpios = <16 0>;
output-high;
@@ -262,7 +262,7 @@
};
&pcie1 {
- status = "okay";
+ status = "okay";
wifi@0,0 {
compatible = "qcom,ath10k";
@@ -272,15 +272,15 @@
};
&usb_phy0 {
- status = "okay";
+ status = "okay";
};
&usb_phy1 {
- status = "okay";
+ status = "okay";
};
&usb0 {
- status = "okay";
+ status = "okay";
hub_port0: port@1 {
reg = <1>;
@@ -290,7 +290,7 @@
};
&usb1 {
- status = "okay";
+ status = "okay";
hub_port1: port@1 {
reg = <1>;